Status

Core Graveyard
File Handling
--
critical
VERIFIED DUPLICATE of bug 132905
16 years ago
2 years ago

People

(Reporter: Milan, Assigned: Bill Law)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Download manager allways crashed after File Save dialog. If I set download to
Progress dialog, this is works.
Mozilla 1.1a  build 2002061104 , OS Windows 2000 + SP2

P.S: I don't uninstalled previous version 1.0 when I install version 1.1a

Comment 1

16 years ago
Could you retry it with fresh install and provide TalkBack ID?
Severity: major → critical
Keywords: crash, stackwanted
(Reporter)

Comment 2

16 years ago
OK, I uninstalled Mozilla, manualy deleted folder "Program files/mozilla.org"
and folder with user settins. Then I installed Mozilla 1.1a again, tried to
download and ... Mozilla crash again. Tallback report has been created, but I
can't found Tallback Report ID (I write commens in Tallback report with this Bug
number).
Sorry for my bad english.

Comment 3

16 years ago
I'm using mozilla 2002061104.
I'm also experiencing problems with download manager.
The problem appears to be a display bug.

When I download a file and save it to the disk with
an 8 bit character in it, the download manager
crashes, but only if it is displayed on the screen.
If I've previously downloaded files and if the
download manager is open, but under another window,
it appears that mozilla wont crash, hence a suspicious
8-bit character display bug.

To test it, just open the <http://www.mozilla.org/>
web page. click with the right button on the main
fram and try to download it. Add the character 'é'
(a e with an accent) in the name of the file. Save
it. If the download manager is displayed, mozilla
crashes.

Comment 4

16 years ago
Probably dupe of bug 132905.

Milan: Run talkback.exe from component directory - there will be talkback id.
Whiteboard: DUPEME
(Reporter)

Comment 5

16 years ago
I try download and  Mozilla crashed again. Crash ID is TB7492697K

Comment 6

16 years ago
I have something similar (Bug #152153). I'm using {BuildID: 2002062109}.
Stack from talkback in comment #5:

nsAssignmentSet::GetAssignmentFor [nsRuleNetwork.cpp, line 596]
nsTemplateMatch::GetAssignmentFor [nsTemplateMatch.cpp, line 52]
nsXULTemplateBuilder::SubstituteTextReplaceVariable [nsXULTemplateBuilder.cpp,
line 1168]
nsXULTemplateBuilder::ParseAttribute [nsXULTemplateBuilder.cpp, line 1077]
nsXULTemplateBuilder::SubstituteText [nsXULTemplateBuilder.cpp, line 1125]
nsXULContentBuilder::BuildContentFromTemplate [nsXULContentBuilder.cpp, line 783]
nsXULContentBuilder::CreateTemplateContents [nsXULContentBuilder.cpp, line 1385]
nsXULContentBuilder::CreateTemplateAndContainerContents
[nsXULContentBuilder.cpp, line 1209]
nsXULContentBuilder::CreateContents [nsXULContentBuilder.cpp, line 1765]
nsXULElement::EnsureContentsGenerated [nsXULElement.cpp, line 3654]
nsXULElement::ChildCount [nsXULElement.cpp, line 2175]
nsXULElement::GetChildNodes [nsXULElement.cpp, line 768]
nsXULElement::GetElementsByTagName [nsXULElement.cpp, line 3684]
nsXULElement::GetElementsByTagName [nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName [nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName [nsXULElement.cpp, line 3718]
nsXULElement::GetElementsByTagName [nsXULElement.cpp, line 1425]
XPTC_InvokeByIndex [xptcinvoke.cpp, line 106]
XPCWrappedNative::CallMethod [xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod [xpcwrappednativejsops.cpp, line 1267]
js_Invoke [jsinterp.c, line 790]
js_Interpret [jsinterp.c, line 2744]
js_Invoke [jsinterp.c, line 806]
js_InternalInvoke [jsinterp.c, line 881]
JS_CallFunctionValue [jsapi.c, line 3426]
nsJSContext::CallEventHandler [nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent [nsJSEventListener.cpp, line 184]
nsXBLPrototypeHandler::ExecuteHandler [nsXBLPrototypeHandler.cpp, line 448]
nsXBLPrototypeHandler::BindingAttached [nsXBLPrototypeHandler.cpp, line 496]
nsXBLPrototypeBinding::BindingAttached [nsXBLPrototypeBinding.cpp, line 441]
nsXBLBinding::ExecuteAttachedHandler [nsXBLBinding.cpp, line 1040]
nsBindingManager::ProcessAttachedQueue [nsBindingManager.cpp, line 913]
nsCSSFrameConstructor::ContentInserted [nsCSSFrameConstructor.cpp, line 9098]
nsCSSFrameConstructor::ContentAppended [nsCSSFrameConstructor.cpp, line 8258]
StyleSetImpl::ContentAppended [nsStyleSet.cpp, line 1527]
PresShell::ContentAppended [nsPresShell.cpp, line 5300]
nsXULDocument::ContentAppended [nsXULDocument.cpp, line 2256]
nsXULContentBuilder::Rebuild [nsXULContentBuilder.cpp, line 1744]
nsXULContentBuilder::Rebuild [nsXULContentBuilder.cpp, line 1753]
XPTC_InvokeByIndex [xptcinvoke.cpp, line 106]
XPCWrappedNative::CallMethod [xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod [xpcwrappednativejsops.cpp, line 1267]
js_Invoke [jsinterp.c, line 790]
js_Interpret [jsinterp.c, line 2744]
js_Invoke [jsinterp.c, line 806]
js_InternalInvoke [jsinterp.c, line 881]
JS_CallFunctionValue [jsapi.c, line 3426]
nsJSContext::CallEventHandler [nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent [nsJSEventListener.cpp, line 184]
nsEventListenerManager::HandleEventSubType [nsEventListenerManager.cpp, line 1222]
nsEventListenerManager::HandleEvent [nsEventListenerManager.cpp, line 1904]
GlobalWindowImpl::HandleDOMEvent [nsGlobalWindow.cpp, line 733]
DocumentViewerImpl::LoadComplete [nsDocumentViewer.cpp, line 1558]
nsDocShell::EndPageLoad [nsDocShell.cpp, line 3957]
nsWebShell::EndPageLoad [nsWebShell.cpp, line 731]
nsDocShell::OnStateChange [nsDocShell.cpp, line 3871]
nsDocLoaderImpl::FireOnStateChange [nsDocLoader.cpp, line 1112]
nsDocLoaderImpl::doStopDocumentLoad [nsDocLoader.cpp, line 771]
nsDocLoaderImpl::DocLoaderIsEmpty [nsDocLoader.cpp, line 669]
nsDocLoaderImpl::OnStopRequest [nsDocLoader.cpp, line 600]
nsLoadGroup::RemoveRequest [nsLoadGroup.cpp, line 537]
imgRequestProxy::OnStopRequest [imgRequestProxy.cpp, line 392]
imgRequest::OnStopRequest [imgRequest.cpp, line 648]
ProxyListener::OnStopRequest [imgLoader.cpp, line 706] 

*** This bug has been marked as a duplicate of 132905 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.