Closed Bug 1518200 Opened 3 years ago Closed 3 years ago

mach test toolkit/components/telemetry/tests/python fails on init. mach python-test works fine.

Categories

(Testing :: Python Test, defect)

Version 3
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1504308

People

(Reporter: chutten, Unassigned)

Details

On Windows 10 (though it might be a problem elsewhere) mach test doesn't like our python tests, showing:

Processing c:\users\image\dev\gecko\third_party\python\certifi
  Requirement already satisfied (use --upgrade to upgrade): certifi==2018.4.16 from file:///C:/Users/image/dev/gecko/third_party/python/certifi in c:\users\image\dev\gecko\testing\web-platform\tests\tools\third_party\certifi
Processing c:\users\image\dev\gecko\third_party\python\pipenv
  Requirement already satisfied (use --upgrade to upgrade): pipenv==2018.5.18 from file:///C:/Users/image/dev/gecko/third_party/python/pipenv in c:\users\image\dev\gecko\obj-debug-i686-pc-mingw32\_virtualenvs\init\lib\site-packages
Processing c:\users\image\dev\gecko\third_party\python\six
  Requirement already satisfied (use --upgrade to upgrade): six==1.10.0 from file:///C:/Users/image/dev/gecko/third_party/python/six in c:\users\image\dev\gecko\obj-debug-i686-pc-mingw32\_virtualenvs\init\lib\site-packages
Processing c:\users\image\dev\gecko\third_party\python\virtualenv
  Requirement already satisfied (use --upgrade to upgrade): virtualenv==15.2.0 from file:///C:/Users/image/dev/gecko/third_party/python/virtualenv in c:\users\image\dev\gecko\obj-debug-i686-pc-mingw32\_virtualenvs\init\lib\site-packages
Processing c:\users\image\dev\gecko\third_party\python\virtualenv-clone
  Requirement already satisfied (use --upgrade to upgrade): virtualenv-clone==0.3.0 from file:///C:/Users/image/dev/gecko/third_party/python/virtualenv-clone in c:\users\image\dev\gecko\obj-debug-i686-pc-mingw32\_virtualenvs\init\lib\site-packages
Building wheels for collected packages: virtualenv-clone
  Running setup.py bdist_wheel for virtualenv-clone ... done
  Stored in directory: C:\Users\image\AppData\Local\pip\Cache\wheels\42\f4\e6\5fe28259c4d0d4ab99ef09e3bb78f39aac871ecabfc7b0386e
Successfully built virtualenv-clone
Error running mach:

    ['test', 'toolkit/components/telemetry/tests/python/']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

TypeError: argument of type 'NoneType' is not iterable

  File "c:\Users\image\dev\gecko\testing/mach_commands.py", line 169, in test
    argv=extra_args, test_objects=tests, **kwargs)
  File "c:\Users\image\dev\gecko\python/mach\mach\registrar.py", line 138, in dispatch
    return self._run_command_handler(handler, context=context, **kwargs)
  File "c:\Users\image\dev\gecko\python/mach\mach\registrar.py", line 95, in _run_command_handler
    result = fn(**kwargs)
  File "c:\Users\image\dev\gecko\python/mach_commands.py", line 99, in python_test
    return self.run_python_tests(*args, **kwargs)
  File "c:\Users\image\dev\gecko\python/mach_commands.py", line 112, in run_python_tests
    self.activate_pipenv(pipfile=None, populate=True, python=python)
  File "c:\Users\image\dev\gecko\python/mozbuild\mozbuild\base.py", line 775, in activate_pipenv
    self.virtualenv_manager.activate_pipenv(pipfile, populate, python)
  File "c:\Users\image\dev\gecko\python/mozbuild\mozbuild\virtualenv.py", line 634, in activate_pipenv
    stderr=subprocess.STDOUT, env=env)
  File "c:\mozilla-build\python\lib\subprocess.py", line 185, in check_call
    retcode = call(*popenargs, **kwargs)
  File "c:\mozilla-build\python\lib\subprocess.py", line 172, in call
    return Popen(*popenargs, **kwargs).wait()
  File "c:\mozilla-build\python\lib\subprocess.py", line 394, in __init__
    errread, errwrite)
  File "c:\mozilla-build\python\lib\subprocess.py", line 599, in _execute_child
    args = list2cmdline(args)
  File "c:\mozilla-build\python\lib\subprocess.py", line 266, in list2cmdline
    needquote = (" " in arg) or ("\t" in arg) or not arg

The tests run fine if you run with mach python-test instead of mach test

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1504308
You need to log in before you can comment on or make changes to this bug.