Closed Bug 1518285 Opened 3 years ago Closed 3 years ago

High ANR rate in 65.0b8

Categories

(Firefox for Android Graveyard :: General, defect, P1)

Firefox 65
Unspecified
Android
defect

Tracking

(firefox64 unaffected, firefox65blocking verified, firefox66+ fixed)

VERIFIED FIXED
Firefox 66
Tracking Status
firefox64 --- unaffected
firefox65 blocking verified
firefox66 + fixed

People

(Reporter: marcia, Assigned: snorp)

References

Details

(Keywords: regression)

While reviewing the GPC I noticed that there was a notification that the ANR rate was above the accepted threshold. This seems to have started around January 5th.

The top issues in the cluster are:

  • executing service org.mozilla.firefox_beta/org.mozilla.gecko.GeckoStarterService
  • executing service org.mozilla.firefox_beta/org.mozilla.gecko.customtabs.GeckoCustomTabsService
    in org.mozilla.gecko.customtabs.GeckoCustomTabsService
  • executing service org.mozilla.firefox_beta/org.mozilla.gecko.GeckoStarterService
    in org.mozilla.gecko.GeckoStarterService

Not sure if Bug 1501748 which just got a fix will take care of the GeckoStarterService issues.

Hi Snorp, Susheel, do we know why the ANRs has spiked on 65beta? This seems concerning.

Flags: needinfo?(snorp)
Flags: needinfo?(sdaswani)

Yeah, I think the fix in 1501748 is what we want here. The cause is from bug 1432019 which landed in 65.

Flags: needinfo?(snorp)

Thanks for a prompt reply. I requested you to nominate a beta patch in bug 1501748.

Snorp has this handled!

Flags: needinfo?(sdaswani)
Severity: normal → blocker

We should verify this once it lands.

Flags: qe-verify+

Encouragingly, the Play Console is showing a drop in ANRs today. Should be able to say by tomorrow if things are back to their old level.

The ANR rate on Beta is back down to where it was in early December, which is also as low as its been in at least the last year. I think we're out of the woods here!

Assignee: nobody → snorp
Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 1501748
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Status: RESOLVED → VERIFIED

Based on comment 7 the QA mobile team considers this bug as verified. I will remove the qe-verify+ flag.

Flags: qe-verify+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.