(picture-caching) Low fps on scrolling pages

RESOLVED FIXED

Status

()

defect
P3
normal
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: sotaro, Assigned: gw)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

When I scrolled paged like https://bugzilla.mozilla.org/show_bug.cgi?id=1494775, fps was very low like 8fps on my laptop(P50 Win10).

Without picture caching, fps was 60fps.

Priority: -- → P3

Potential fix / workaround is https://github.com/servo/webrender/pull/3487 - although I'd still like to see some WR profile graphs of this case, since the difference is very significant and I can't repro here.

Sotaro, can you still reproduce? If so can post WR profile graphs.

Flags: needinfo?(sotaro.ikeda.g)
Assignee: nobody → gwatson

(In reply to Sotaro Ikeda [:sotaro] from comment #0)

When I scrolled paged like https://bugzilla.mozilla.org/show_bug.cgi?id=1494775, fps was very low like 8fps on my laptop(P50 Win10).

Without picture caching, fps was 60fps.

The low fps problem is addressed on the above Bugzilla page, but scrolling of https://www.yahoo.co.jp/ was still not smooth on my laptop(P50 Win10). The page was smooth without picture caching.

profile(with picture caching) is https://perfht.ml/2FIRAtj

Flags: needinfo?(sotaro.ikeda.g)

I checked with latest nightly. fps was close to 60fps. It seems good to close it.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.