Most panel footer buttons don't have a focus ring on Linux and Mac

RESOLVED FIXED in Firefox 66

Status

()

defect
P1
normal
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: dao, Assigned: dao)

Tracking

({access})

Trunk
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox64 wontfix, firefox65 wontfix, firefox66 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

5 months ago
No description provided.
Assignee

Updated

5 months ago
OS: Linux → All
Summary: Most panel footer buttons don't have a focus ring on Linux → Most panel footer buttons don't have a focus ring on Linux and Mac
Attachment #9034958 - Attachment description: Bug 1518422 - Implement focus ring for panel footer buttons on Linux. r=ntim → Bug 1518422 - Implement focus ring for panel footer buttons across platforms. r=ntim

Comment 2

5 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/922a9d4b4b49
Implement focus ring for panel footer buttons across platforms. r=ntim

Comment 3

5 months ago

With the current patch, it seems like macOS would have two different focusrings ? -moz-mac-focusring for .popup-notification-button and the Windows/Linux outline for the other footers.

Is this intentional ?

Flags: needinfo?(dao+bmo)
Assignee

Comment 4

5 months ago

It was intentional as it's not clear to me how -moz-mac-focusring would work when the button is blue, but I'm open to changing this in a followup. I don't think it matters much on Mac anyway since users need to enable full keyboard access for this to be used at all.

Flags: needinfo?(dao+bmo)

Comment 5

5 months ago

(In reply to Dão Gottwald [::dao] from comment #4)

It was intentional as it's not clear to me how -moz-mac-focusring would work when the button is blue, but I'm open to changing this in a followup.

-moz-mac-focusring is not always blue, but either way, if we don't want the .popup-notification-button -moz-mac-focusring, then that rule should probably get removed to get a consistent focusring ?

https://searchfox.org/mozilla-central/rev/76fe4bb385348d3f45bbebcf69ba8c7283dfcec7/toolkit/themes/osx/global/notification.css#11-14

Flags: needinfo?(dao+bmo)
Assignee

Comment 6

5 months ago

(In reply to Tim Nguyen :ntim from comment #5)

(In reply to Dão Gottwald [::dao] from comment #4)

It was intentional as it's not clear to me how -moz-mac-focusring would work when the button is blue, but I'm open to changing this in a followup.

-moz-mac-focusring is not always blue,

I wasn't asserting that it's always blue.

but either way, if we don't want the .popup-notification-button -moz-mac-focusring, then that rule should probably get removed to get a consistent focusring ?

https://searchfox.org/mozilla-central/rev/76fe4bb385348d3f45bbebcf69ba8c7283dfcec7/toolkit/themes/osx/global/notification.css#11-14

Right.

Flags: needinfo?(dao+bmo)

Updated

5 months ago
Depends on: 1518452

Comment 7

5 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

Did you want to nominate this for Beta uplift? It grafts cleanly.

Flags: needinfo?(dao+bmo)
Assignee

Comment 9

4 months ago

Since this isn't a regression and practically only Linux ia affected, I think this can just ride the 66 train.

Flags: needinfo?(dao+bmo)
You need to log in before you can comment on or make changes to this bug.