Closed Bug 1518442 Opened 11 months ago Closed 2 months ago

Implement Event-based form participation

Categories

(Core :: DOM: Core & HTML, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox71 --- fixed

People

(Reporter: tkent, Assigned: jdai)

References

Details

(Keywords: dev-doc-complete)

Attachments

(5 files)

The HTML specification introduces 'formdata' event.

Specification PR: https://github.com/whatwg/html/pull/4239
WPT PR: https://github.com/web-platform-tests/wpt/pull/14637

Note: Chrome already implemented it behind the experimental flag.

Depends on: 1519329
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Depends on: 1530591

Before working on this, I wanted to confirm that there is not already a "constructing entry list" flag and an "entry list" (or akin concept/definitions/declarations) in our implementation of HTMLFormElement. HTMLFormElement.cpp is a rather complex/large beast, so I'm wondering who might be a good DOM Peer to work with on it? I doubt there is, but don't want to dive in without a plan.

Some of the basic changes that needed are here:
https://whatpr.org/html/4239/edc1e95...ee10279/form-control-infrastructure.html#constructing-form-data-set

baku has been dealing with form submission quite a bit :)

It's part of form participation API[1] which allows arbitrary objects can participate in form submission. Since baku unassigned bug 1519329, I'll contine working this bug.

[1] https://docs.google.com/document/d/1JO8puctCSpW-ZYGU8lF-h4FWRIDQNDVexzHoOQ2iQmY

Assignee: nobody → jdai
Status: NEW → ASSIGNED
Duplicate of this bug: 1530591
Duplicate of this bug: 1519329
Pushed by jdai@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e7a459689227
Part 1: Implement FormDataEvent interface; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/c8fbe42eba38
Part 2: Implement Event-based form participation; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/65f7059b0080
Part 3: Add dom.formdata.event.enabled preference for Event-based form participation; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/1df8f544b3b7
Part 4: Fix wpt test for Event-based form participation; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/a092042068ab
Part 5: Add a mochitest for pref-off form data event attribute; r=smaug,edgar
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/74c27d7d13c5
Part 6: Fix idlharness.https.html wpt test for Event-based form participation; r=jdai

Please help me back-out the patches because I miss setting default pref-on for part 6. The part 6 wpt tests will fail in beta and release channel.

Pushed by jdai@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f280db1076a4
Part 1: Implement FormDataEvent interface; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/1ac7b20bb1d8
Part 2: Implement Event-based form participation; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/1f3d36108982
Part 3: Add dom.formdata.event.enabled preference for Event-based form participation; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/b1b08f66996c
Part 4: Fix wpt test for Event-based form participation; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/9143aef9bd5e
Part 5: Add a mochitest for pref-off form data event attribute; r=smaug,edgar
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/18910 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.

This added a ini file to the web-platform-tests tests directory instead of the metadata directory: https://github.com/web-platform-tests/wpt/pull/18910

Flags: needinfo?(jdai)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla71 → ---

(In reply to Josh Matthews [:jdm] from comment #22)

This added a ini file to the web-platform-tests tests directory instead of the metadata directory: https://github.com/web-platform-tests/wpt/pull/18910

I also found this mistake, I already request backout.

Flags: needinfo?(jdai)
Upstream PR was closed without merging
Pushed by jdai@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bc978c5a71a6
Part 1: Implement FormDataEvent interface; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/220138300dd8
Part 2: Implement Event-based form participation; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/975942e56797
Part 3: Add dom.formdata.event.enabled preference for Event-based form participation; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/8a0b9824539d
Part 4: Fix wpt test for Event-based form participation; r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/e51f7562204d
Part 5: Add a mochitest for pref-off form data event attribute; r=smaug,edgar
Regressions: 1580177
Blocks: 1594708

I've written docs for this feature; see https://github.com/mdn/sprints/issues/2273#issuecomment-555207411 for the full details.

Please let me know if you think this needs anything else. Thanks!

You need to log in before you can comment on or make changes to this bug.