Closed Bug 1518451 Opened 9 months ago Closed 9 months ago

Issues running Dedicated profile with Profile Manager

Categories

(Toolkit :: Startup and Profile System, defect, major)

defect
Not set
major

Tracking

()

RESOLVED FIXED
Tracking Status
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected

People

(Reporter: Ovidiu, Assigned: mossop)

References

Details

(Whiteboard: qablocker )

[Affected platforms]:

Tested on Mac OS X 10.14 and Windows 10

[Steps to reproduce]:

Prerequisites: Set up the browser to open Profile Manager

  1. Open a build that has a dedicated profile set up
  2. Close the browser
  3. Open again the build from step 1

[Actual result]:

The browser does not open.

[Expected result]:

The browser should open.

Note:
If the Profile Manager is not activated the issue is not reproducible. Here is a video with the issue: https://streamable.com/mvlsq

Blocks: 1474285
Whiteboard: qablocker
Assignee: nobody → dtownsend

Ok, figured this out. Will do some builds later today that fix this.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

First time when you open the browser after you've installed it the Profile Manager is not prompted. If I restart the browser the Profile Manager is shown, I want to know if this is the expected behaviour, or we should see the Profile Manager at first start of the browser?

Flags: needinfo?(dtownsend)

(In reply to ovidiu boca[:Ovidiu] from comment #2)

First time when you open the browser after you've installed it the Profile Manager is not prompted. If I restart the browser the Profile Manager is shown, I want to know if this is the expected behaviour, or we should see the Profile Manager at first start of the browser?

This is kind of a carry over from previous behaviour. If Firefox had never been run (there are no profiles) but (somehow?) has a profiles.ini that says to always show the profile manager it would just create a new profile and mark it as default.

So the new code, if it thinks it is the first run of an install (determined by seeing if it has ever had a default profile assigned to it) we ignore that setting and just create a new default profile.

I lean towards this being correct, showing the profile manager would tempt users to just select a profile that is for a different install, but let's hear what Romain and Michael think.

Flags: needinfo?(rtestard)
Flags: needinfo?(mverdi)
Flags: needinfo?(dtownsend)

On first run after the update users would get a new profile created and have a chance to be educated about the new behavior - they can still close the browser and re-open it to see the profile manager.
If I get this right, I agree that the current behavior on first run seems correct since otherwise profile manager + information UI would be very confusing.

My recollection of what we want when the profile manager is set to open automatically:
1 If browser install is eligible for a new default profile, set new default profile and inform the user per agreed UI
2 Close the browser
3 Open the browser, see the profile manager

Flags: needinfo?(rtestard)

(In reply to Dave Townsend [:mossop] (he/him) from comment #3)

So the new code, if it thinks it is the first run of an install (determined by seeing if it has ever had a default profile assigned to it) we ignore that setting and just create a new default profile.

I lean towards this being correct, showing the profile manager would tempt users to just select a profile that is for a different install, but let's hear what Romain and Michael think.

Yes, I agree.

Flags: needinfo?(mverdi)
You need to log in before you can comment on or make changes to this bug.