Closed Bug 15185 Opened 21 years ago Closed 20 years ago

SELECT box does not fill with javascript function (onchange event)

Categories

(Core :: DOM: Core & HTML, defect, P3, major)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 15133

People

(Reporter: keith.lesch, Assigned: vidur)

References

()

Details

When you select an item in the first select box, the second select box (user)
should fill with a list.  The list for "my" is only 4 names, while the list for
"your" is many more.  Nothing happens on either of these events.  A login cannot
be successfully completed unless all 3 of these elements are submitted.

I have created this page solely for your use at mozilla.  It is a duplication of
the major features of another page which you cannot access, therefore it will
not submit to any particular page, but produce a page not found error when you
get it working.  There are two major problems with this page which cause the
entire application behind it to be inaccessible.
Assignee: mccabe → vidur
Severity: critical → major
Component: Javascript Engine → DOM Level 0
I'm seeing (in Linux viewer 1999-09-29):

JavaScript Error: ReferenceError: LoginForm is not defined
URL: http://worldzone.net/misc/lesch/main.html
LineNo: 283

which probably means the JS isn't running at all.

The problem seems to be that the form object isn't available directly within the
event handlers on the form elements.

Changing component to DOM Level 0 and reassigning.  This is not a core
javascript bug.

Reducing severity from critical to major.  Perhaps it should just be normal?
QA Contact: cbegle → desale
CCing Eric Pollmann for more input.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 15133 ***
Status: RESOLVED → VERIFIED
Tested with 10-15-09. Duplicate.
You need to log in before you can comment on or make changes to this bug.