Closed Bug 1518500 Opened 2 years ago Closed 5 months ago

The 'Flexible Space' item disappears from the customization pallette after adding it to the right side of the bookmark toolbar

Categories

(Firefox :: Toolbars and Customization, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 75
Tracking Status
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- verified

People

(Reporter: cbaica, Assigned: Gijs)

References

Details

Attachments

(2 files)

[Affected versions]:

  • Fx 64.0 RC
  • Fx 65.0b9
  • Fx 66.0a1

[Affected platforms]:

  • macOS 10.11
  • Ubuntu 16.04 x32
  • Windows 10 x64

[Steps to reproduce]:

  1. Launch Firefox.
  2. Enable the bookmark toolbar.
  3. Open the Hamburger menu and click on the 'Customize'.
  4. Drag the 'Flexible Space' on the right side of the bookmark toolbar.

[Expected result]:

  • The 'flexible space' item is available to be added in other places after it is dropped on the bookmark toolbar.

[Actual result]:

  • The 'flexible space' item is removed from the customization pallette.

[Regression range]:
Will get back with a regression range ASAP.

[Additional notes]:
If the user re-enters the Customization mode, the flexible space item will be available again.

This does not look like a regression. I have tracked the issue back to the following push log:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a418121d46250f91728b86d9eea331029c264c30&tochange=09a4282d1172ac255038e7ccacfd772140b219e2

That is when the Flexible Space item was added to the Customization mode: 1366813.

Priority: -- → P3

(The good news is that the flexible space comes back if Customize Mode is closed and re-opened)

Flags: needinfo?(gijskruitbosch+bugs)
Duplicate of this bug: 1603931

Before this patch, we change aDraggedItemId somewhat late in the _applyDrop method -
significantly, we do this after the aTargetNode == areaCustomizationTarget check. So
we end up bailing out before adjusting aDraggedItemId, and we add the specific dummy
item from the palette into the toolbar, rather than adding a new spring to the
toolbar, and leaving the existing palette item alone.

Simply moving this adjustment to aDraggedItemId earlier into the method is sufficient
to fix the issue at hand.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4d96076060c7
ensure we don't end up without a flexible space if moving items directly to toolbars, r=dao
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Flags: qe-verify+
Flags: needinfo?(cristian.baica)

Tested using Fx75.0b5 on windows 10, Ubuntu 18.04 and macOS 10.13. The flexible space no longer disappears after being added to the bookmark toolbar.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(cristian.baica)
You need to log in before you can comment on or make changes to this bug.