Open Bug 1518529 Opened 2 years ago Updated 1 year ago

Bookmarks saved for non-secure sites (http) don't show for secure (https) sites

Categories

(Firefox :: Bookmarks & History, defect, P3)

defect

Tracking

()

People

(Reporter: mberlinger, Unassigned)

References

Details

(Whiteboard: [fxsearch])

[Affected versions]:

  • 66.0a1
  • 65.0b9
  • 64.0

[Affected platforms]:

  • Windows 10 x64
  • Windows 7 x64
  • Ubuntu 16.04 x64
  • mac OS 10.13 x64

[Steps to reproduce]:

  1. Launch Firefox with a dirty profile.
  2. Open random bookmarked websites.

[Expected result]:

  • All accessed sites have blue star.

[Actual result]:

  • Not all websites have blue star even if they are in bookmarked.

[Regression range]:

  • I don’t think this is a regression since I was able to reproduce it on Firefox 55.0.3

Have you checked the websites haven't redirected to other pages from what was originally bookmarked?

If they haven't, please can you include some examples here.

Flags: needinfo?(maria.berlinger)

Yes, I checked the URL and for some websites is the same URL and they're not bookmarked. (e.g. http://www.imdb.com/ , http://pocketnow.com/ ) those two are in bookmark toolbar from dirty profile.
It is possible to be because of the secure connection, links have been saved with http and when you access them they are redirected to https. Could be this the problem here, any idea?

You can download the dirty profile from: https://drive.google.com/file/d/1s7yHm00y_lP_SL5yjfJrcD2Hc6BxtGYW/view?usp=sharing

Flags: needinfo?(maria.berlinger) → needinfo?(standard8)

Yes, the http vs https is an issue here - they are seen as a different site, even though http might be permanently redirecting to https.

We should investigate this at some stage. Handling http -> https might be a relatively simple case to get right, especially with the current move towards secure sites.

Flags: needinfo?(standard8)
Priority: -- → P3
See Also: → 1366485
Summary: The star-shape button does not turn blue for certain bookmarked websites → Bookmarks saved for non-secure sites (http) don't show for secure (https) sites
Whiteboard: [fxsearch]
Duplicate of this bug: 1563250

Some website pages like:
http://ultronbrowser.io/
https://ultronbrowser.io/
are still different in HTTP and HTTPS, so I don't think it's good idea now to merge HTTP and HTTPS bookmarks into one.

Especially when many non HTTP website pages are still using HTTPS onle as login into administrator account. Unfortunately it's still widely used on government website pages:

example 1:
http://gis.gdansk.pl/
https://gis.gdansk.pl/

example 2:
http://portalgis.gdansk.rdos.gov.pl/
https://portalgis.gdansk.rdos.gov.pl/

I have many website pages like this in my bookmarks.

You need to log in before you can comment on or make changes to this bug.