Closed Bug 1518804 Opened 10 months ago Closed 10 months ago

Devtools debugger panel button tooltip showing shortcut undefined

Categories

(DevTools :: Debugger, defect, P2)

66 Branch
Unspecified
All
defect

Tracking

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 unaffected, firefox66 fixed)

RESOLVED FIXED
Firefox 66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: yohanmishkin, Assigned: pdahiya)

References

Details

(Keywords: regression, Whiteboard: [66b-qatriage-p2])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Opened devtools and hovered over the Debugger panel button.

Actual results:

The tooltip appeared (as seen in the attached screenshot) as "Javascript Debugger (undefined)".

Expected results:

The tooltip should have appeared as "Javascript Debugger (Cmd+Opt+S)".

I found the code responsible for generating the tooltips in client/definitions.js so I'd be happy to poke around for a solution if this is something that would get merged.

Looks like this is where the issue was introduced. Looks like this was intended, closing this out.

Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → WORKSFORME

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0
20190109214248

(In reply to yohanmishkin from comment #0)

Actual results:

The tooltip appeared (as seen in the attached screenshot) as "Javascript Debugger (undefined)".

Expected results:

The tooltip should have appeared as "Javascript Debugger (Cmd+Opt+S)".

As you've discovered, the keyboard shortcut was intentionally removed in bug 1502924. The tooltip should simply say "JavaScript Debugger".

Blocks: 1502924
Status: RESOLVED → UNCONFIRMED
Has STR: --- → yes
Component: Untriaged → Debugger
Flags: needinfo?(pdahiya)
Keywords: regression
OS: Unspecified → All
Product: Firefox → DevTools
Resolution: WORKSFORME → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true

Regression caused due to missed localization string update, will submit patch with updated strings. Thanks for catching it.

https://searchfox.org/mozilla-central/source/devtools/client/locales/en-US/startup.properties#77

Flags: needinfo?(pdahiya)
Assignee: nobody → pdahiya
Priority: -- → P2
Devtools debugger panel button tooltip showing shortcut undefined
Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d39ee6115c27
Devtools debugger panel button tooltip shows undefined r=jlast
Status: NEW → RESOLVED
Closed: 10 months ago10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Whiteboard: [66b-qatriage-p2]
You need to log in before you can comment on or make changes to this bug.