Closed Bug 1518808 Opened 2 years ago Closed 1 year ago

Add accessibility highlighter infobar information for nodes that fail text-label audit.

Categories

(DevTools :: Accessibility Tools, enhancement)

enhancement
Not set
normal

Tracking

(firefox69 fixed)

RESOLVED FIXED
Firefox 69
Tracking Status
firefox69 --- fixed

People

(Reporter: yzen, Assigned: yzen)

References

Details

Attachments

(1 file)

For accessibles that require a name (such as the ones that are interactive) we need to let the user know about the missing name. One of the places where we can bring attention to that is the a11y highlighter.

See Also: → 1473043
Summary: Add missing name warning for accessibles when using a highlighter. → Add accessibility highlighter infobar information for nodes that fail text-label audit.
Assignee: nobody → yzenevich
Status: NEW → ASSIGNED
Blocks: 1552067
Attachment #9074058 - Attachment description: Bug 1518808 - add accessibility highlighter infobar for text label audit. r=nchevobbe → Bug 1518808 - add accessibility highlighter infobar for text label audit. r=nchevobbe, flod
Attachment #9074058 - Attachment description: Bug 1518808 - add accessibility highlighter infobar for text label audit. r=nchevobbe, flod → Bug 1518808 - add accessibility highlighter infobar for text label audit. r=nchevobbe,flod
Attachment #9074058 - Attachment description: Bug 1518808 - add accessibility highlighter infobar for text label audit. r=nchevobbe,flod → Bug 1518808 - add accessibility highlighter infobar for text label audit. When accessible object does not pass text label accessibility audit, the infobar will display a short message describing the particular labeling issue. r=nchevobbe,flod
Duplicate of this bug: 1473043
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e677852d2ea5
add accessibility highlighter infobar for text label audit. When accessible object does not pass text label accessibility audit, the infobar will display a short message describing the particular labeling issue. r=nchevobbe,flod
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/35d33e763422
add accessibility highlighter infobar for text label audit. When accessible object does not pass text label accessibility audit, the infobar will display a short message describing the particular labeling issue. r=nchevobbe,flod
You need to log in before you can comment on or make changes to this bug.