Pressing backspace in a text field makes the caret (cursor) flash in the beginning of the field

RESOLVED FIXED in mozilla1.2beta

Status

()

Core
Layout: Form Controls
P2
minor
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: Vladimir Ermakov, Assigned: kinmoz)

Tracking

({regression})

Trunk
mozilla1.2beta
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

(Reporter)

Description

16 years ago
When deleting text using backspace the cursor periodically flashes in the
beginning of the text field/text area. 

To Reproduce:
  1) place the cursor in the text field at the end of a long string(URL bar
works best) 
  2) Hold down backspace and observe the beginning of the text field

EXPECTED: Cursor doesnt get there until the text is deleted
ACTUAL: Cursor flashes there periodically. And in the case of the URL/Location
bar it is there almost all the time while the backspace is held down.

Build: 2002-06-14-08-trunk on windows 98

Comment 1

16 years ago
-->
Assignee: rods → kin
(Assignee)

Comment 2

16 years ago
This was due to my fix which made text widgets use async reflow/paint/scrolling
in bug 141900. The flashing is due to the auto variable that hides the caret in
nsEditor::EndUpdateViewBatch().
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla1.1beta

Comment 3

16 years ago
I don't know if it's this bug or bug 151682 or another bug, but since bug 141900
was fixed, typing in the url bar appears much slower, mostly when the
autocomplete match list is dropped down.  A couple of times when my CPU is busy,
I've been able to type an entire url, hit enter, and have the page start loading
before anything is updated in the url bar.  Mostly, though, it's that characters
I type don't immediately show up, just white space.
nsbeta1+.
Keywords: nsbeta1+, regression
Whiteboard: [adt3]
Target Milestone: mozilla1.1beta → mozilla1.2beta

Comment 5

16 years ago
*** Bug 169386 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
This affects Chimera on OS X too.
OS: Windows 98 → All
Hardware: PC → All
(Assignee)

Updated

16 years ago
Depends on: 141900

Updated

16 years ago
Summary: Pressing backspace in a text field makes the cursor flash in the beginning of the field → Pressing backspace in a text field makes the caret (cursor) flash in the beginning of the field

Comment 7

16 years ago
*** Bug 173682 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
I just discovered a new behaviour that could be related to this bug :
Have a page with an animated GIF and a text input form. Have the frames of the 
gif change at different intervals, not the same inverval. 
The cursor in the input field blinks in rythm with the changes in the animated 
gif.

This happened on some bulleitn board pages and the gif was an ad banner. Not 
always reproductible and I can't tell if it is precisely related to the gif 
(though visually it seems so) or related to javascript visual effects.
(Assignee)

Comment 9

16 years ago
Andrei the bug you mention is bug 54153, and it's related to anything that
paints a part of the page on a regular basis, as animated gifs do. Interestingly
enough, IE also has the same problem. I may land the fix in bug 54153 in the
1.3alpha time frame.
(Assignee)

Updated

16 years ago
Blocks: 174823
(Assignee)

Comment 10

16 years ago
This bug has been temporarily fixed with the checkin of attachment 101640 [details] [diff] [review] from
bug 141900 during the mozilla1.2beta milestone. It basically disables the code
which landed as part of attachment 87307 [details] [diff] [review] (async reflow and painting for text
widgets) until all issues blocking bug 174823 can be resolved.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.