RFE: Add Prefs to right click of QuickLaunch Icon

VERIFIED WONTFIX

Status

Core Graveyard
QuickLaunch (AKA turbo mode)
--
enhancement
VERIFIED WONTFIX
16 years ago
5 years ago

People

(Reporter: alanjstr, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
In order to change my preferences, I have to open the full browser window and
then pick from the drop-downs.  I'd like to be able to right-click the tray icon
and see an option for that.

Comment 1

16 years ago
-> ui design for a decision...
Assignee: ben → mpt
Status: UNCONFIRMED → NEW
Component: Preferences → User Interface Design
Ever confirmed: true
QA Contact: sairuh → zach

Comment 2

15 years ago
uid is being phased out.
Assignee: mpt → law
Component: User Interface Design → QuickLaunch (AKA turbo mode)
QA Contact: zach → gbush

Comment 3

15 years ago
no
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 4

15 years ago
verified
Status: RESOLVED → VERIFIED

Comment 5

15 years ago
*** Bug 212253 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
Why has this been marked as a "WONTFIX"? The preferences are used in all the other apps... how difficult can it be to add it to this one?
(Reporter)

Comment 7

15 years ago
They're getting rid of quicklaunch.

Comment 8

15 years ago
Is there an intended replacement to quicklaunch? or is this due to each app being separate?

Comment 9

15 years ago
the intended replacement is simply that each (separate) app launches quickly
without assistance from being pre-loaded.

Comment 10

15 years ago
I didn't think quicklaunch made much difference on performance... but I have always liked the fact that I can launch the apps from a single menu. Maybe a taskbar item could be created and that installed apps add (and remove) themselves on the menu list (maybe via Registry on MSWin). Comments?

Are the preferences still going to be consistent over each app or are each going to be a completely separate entity?
(Reporter)

Comment 11

15 years ago
There are already Windows utilities that allow you to create a tray icon and
hook up various apps to it.

What does this have to do with preference consistency?

There may be some project down the road to preload the GRE.

Comment 12

15 years ago
If the preferences were consistent for all apps (i.e. one preference dialog manages all registered components - as they do now with calander and other xpi modules) then it could be managed under the new "quicklaunch".

Could you explain the GRE? I couldn't find any project by that name... but have seen it referenced in places.
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.