Status

()

defect
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: kats, Assigned: kats)

Tracking

Other Branch
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

Now that the wrench jobs (for testing WR standalone) have been baked for a few days I'd like to make them tier-1 so that if they go orange, stuff gets backed out. This is a prerequisite to successfully porting WR changes from m-c to the github repo and making m-c the canonical repo for WR.

Also for the record I went through the list of requirements at https://wiki.mozilla.org/Sheriffing/Job_Visibility_Policy for tier-1 jobs and did my best to check all the boxes for these jobs. A few caveats, though: these jobs aren't quite like existing gecko test suites in that they do a combination of checking different compilation flags and correctness via reftests, but of WebRender in isolation. So things like "getting crash stacks using mozcrash" isn't applicable because we're just running rust binaries instead of firefox.

Also, these jobs are not scheduled on every push, but they do run anytime the gfx/wr folder (or if any of the taskcluster scripts that run the tests) is modified. This is effectively SETA but more precise. The jobs can be backfilled by sheriffs if needed to verify a regression.

I've added a doc page at https://developer.mozilla.org/en-US/docs/Mozilla/QA/WebRender and linked it to https://developer.mozilla.org/en-US/docs/Mozilla/QA/Automated_testing. The page provides an overview of the jobs and how to run them on try/locally (where possible).

Comment 3

6 months ago
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d4320750e1bf
Promote WR standalone CI jobs to tier-1. r=aryx

Comment 4

6 months ago
bugherder
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.