Closed Bug 1518911 Opened 10 months ago Closed 7 months ago

Call TabChild::MakeHidden and TabChild::MakeVisible for all oop-iframes when switching tabs

Categories

(Core :: Layout, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1525720

People

(Reporter: jwatt, Assigned: rhunt)

References

(Blocks 2 open bugs)

Details

The root presContext is told to change the state of any plugins to “hidden” whenever a Tab is hidden (by TabChild::MakeHidden). Notifying the root presContext of the top-level document won't be enough in a Fission world. We'll need to notify all oop-frames too.

"In early 2020, Flash support will be completely removed from consumer versions of Firefox. The Firefox Extended Support Release (ESR) will continue to support for Flash until the end of 2020."
https://developer.mozilla.org/en-US/docs/Plugins/Roadmap

So it seems to me that making the "PluginGeometryUpdates" parts of
TabChild::MakeHidden work in a Fission world is very low priority.
I expect all that code to be removed once we stop supporting plugins.
(Please correct me if I'm missing something.)

So I wonder if we could get away with simply not supporting Flash
in OOP <iframes> at all?

Maybe.

Just to be clear, this bug is about nsRootPresContext::ComputePluginGeometryUpdates.

Blocks: 1523439

needinfo is just to make sure you're aware of this bug in case it duplicates anything gfx is working on.

Flags: needinfo?(rhunt)

Neha, do you know the answer to comment 2?

Flags: needinfo?(nkochar)

(In reply to Mats Palmgren (:mats) from comment #1)

"In early 2020, Flash support will be completely removed from consumer versions of Firefox. The Firefox Extended Support Release (ESR) will continue to support for Flash until the end of 2020."
https://developer.mozilla.org/en-US/docs/Plugins/Roadmap

So it seems to me that making the "PluginGeometryUpdates" parts of
TabChild::MakeHidden work in a Fission world is very low priority.
I expect all that code to be removed once we stop supporting plugins.
(Please correct me if I'm missing something.)

Considering flash to not be supported starting early 2020, I think it is a safe bet to not support Flash for OOP iframes.

Flags: needinfo?(nkochar)
Assignee: nobody → rhunt
Summary: Notify oop-iframes when the tab is hidden/shown → Call TabChild::MakeHidden and TabChild::MakeVisible for all oop-iframes when switching tabs

I'm actually just going to duplicate this with bug 1525720 and do the work there.

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(rhunt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1525720
You need to log in before you can comment on or make changes to this bug.