underline and collapsing trailing whitespace

VERIFIED DUPLICATE of bug 4248

Status

()

defect
P2
normal
VERIFIED DUPLICATE of bug 4248
21 years ago
20 years ago

People

(Reporter: howcome, Assigned: buster)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

21 years ago
Section (7) in the test page shows two problems with underlining in nglayout.

First, setting "text-decoraion: none" on a child element should not turn off an
underline set on a parent element. This may seem counter-intuitive, but there
are good reasons for it. The CSS WG is likely to add functionality to turn off
underlining at a later point. Section 5.4.3 in CSS1 describes the behavior:

"This property is not inherited, but elements should match their parent. E.g.,
if an element is underlined, the line should span the child elements."

The second problem shown on the test page is not about CSS, but how white space
is collapsed in nglayout. I belive the underlined space character after "have a"
and "the text." should have been collapsed.

Updated

21 years ago
Assignee: peterl → kipp

Comment 1

21 years ago
The underlining works as specified now.
Kipp: what about collapsing the trailing whitespace?

Updated

21 years ago
Status: NEW → ASSIGNED

Comment 2

21 years ago
Setting all current Open/Normal to M4.

Updated

21 years ago
Summary: underline → underline and collapsing trailing whitespace
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Target Milestone: M15
The trailing space issue is covered by bug 4248. I will mark this bug as such
and copy the comments over.


*** This bug has been marked as a duplicate of 4248 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 5

20 years ago
Verified Dup
You need to log in before you can comment on or make changes to this bug.