Pixel-specific css font sizes are rendered taller in 1.1 than in 1.0

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
--
minor
RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: Gordon McNaughton, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
See the example page at http://www.whitelite.net/files/Mozilla/font.html

A css font size like this: 
.TimesRoman12 { font-family: Times; font-size: 16px; }

...will be rendered slightly taller in Moz 1.1a than in 1.0 (which agrees with 
IE6 and NS 6/7).  This screws up pages which rely on all browsers displaying 
pixel-locked font sizes with the same vertical alignment.  Changing rendering 
DPI does not appear to make a difference, nor does switching the page out of 
quirks mode (then none of the browsers -- IE 6, Moz 1.0, and 1.1a -- agree).
(Reporter)

Comment 1

16 years ago
Created attachment 87724 [details]
Example html displaying the css pixel font size problem.

Try viewing the attached HTML in IE, Moz 1.0, and Moz 1.1a.  Pay close
attention to the height of the block of links (they're underlined to make the
difference easier to see, but non-linked text has the same discrepancy).
(Reporter)

Updated

16 years ago
Summary: Pixel-specific css font sizes are rendered slightly than before → Pixel-specific css font sizes are rendered taller in 1.1 than in 1.0
Is this still an issue with a current build?
(Reporter)

Comment 3

16 years ago
Yeah, this problem still occurs under 1.3b (I don't have the latest nightly
though).  I'll attach a screenshot of a side-by-side between a couple of
different browsers in Win2k.
(Reporter)

Comment 4

16 years ago
Created attachment 114804 [details]
A side-by-side comparison of IE6, NS4, NS 7, and Moz 1.3b displaying css-px-locked fonts

Here's a picture that illustrates the problem... the same block of text
displays slightly differently in >= Moz 1.1a than it does in IE6, NS4, or Moz
1.0 (which all agree).	The text is locked to a px size using css.
So it looks like our line-height is set just a smidge bigger than IE's and
netscape's....

I'm not sure we should change this -- I find Mozilla's rendering a lot more
readable and pages that rely on the font size are breaking right and left anyway
(user stylesheets, minimum font sizes, text zoom, etc).
Component: Layout → Layout: Fonts and Text
(Reporter)

Comment 6

16 years ago
Hmm, good point. :)  It would be nice to keep compatibility where possible
though.  Is quirks rendering mode still supported?  If so, would it be possible
to render a compatible line height in quirks mode but not in normal mode?

Updated

14 years ago
Keywords: testcase

Comment 7

12 years ago
This bug still exists on Gecko/20060529 Minefield/3.0a1 nightly trunk. 
Is this bug still relevant? 
IMO, no. Every web page is able to set the line-height setting. 
If yes, it Status should be 'New'? (although somehow ironic)
Assignee: attinasi → nobody
QA Contact: chrispetersen → layout.fonts-and-text
(Reporter)

Comment 8

12 years ago
I would still be happy to see it fixed (at least in quirks mode) so that quirks-mode Moz will emulate older browsers (IE6) as closely as possible.  If I can find an appropriate CSS line-height workaround, I'll post it here.
Not sure which engine's rendering changed, but Firefox and IE11 has same line height on this demo
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.