Crash switching tabs while Quicktime plays [@ QuickTimeStreaming.qtx]

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: jelwell, Assigned: jag+mozilla)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

17 years ago
Steps to reproduce:
1) I had no tabs open.
2) Load URL
3) Click on "Click to play"
4) While the ad is playing highlight some text on the right in the page to give
the browser focus.
5) Hit CTRL-T to open a new tab.

Actual Results:
Browser crashes.

Expected Results:
no crash.

I'm using 20020612 commercial build, with Quicktime 5.
(Reporter)

Comment 1

17 years ago
Talkback:

http://climate/reports/SingleIncidentInfo.cfm?dynamicBBID=7349942

Stack Trace

DocumentViewerImpl::CreateStyleSet
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 4700]
DocumentViewerImpl::SetDOMDocument
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 1677]
nsDocShell::CreateAboutBlankContentViewer
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 4032]
nsDocShell::EnsureContentViewer
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 3967]
nsDocShell::GetInterface
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 312]
nsWebShell::GetInterface
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 294]
nsGetInterface::operator()
[d:\builds\seamonkey\mozilla\xpcom\base\nsIInterfaceRequestor.cpp, line 55]
nsCOMPtr_base::assign_from_helper
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp, line 81]
GlobalWindowImpl::GetDocument
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 864]
nsWindowSH::CacheDocumentProperty
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 3612]
nsWindowSH::NewResolve
[d:\builds\seamonkey\mozilla\dom\src\base\nsDOMClassInfo.cpp, line 3864]
XPC_WN_Helper_NewResolve
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 906]
js_LookupProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2251]
js_GetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2455]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2576]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 806]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 881]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3426]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1019]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 182]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1220]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1830]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3461]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3480]
nsEventStateManager::DispatchNewEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventStateManager.cpp, line 4077]
nsXULElement::DispatchEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 1854]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2028]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 790]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2744]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 806]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 881]
js_SetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2616]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2586]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 806]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 881]
js_SetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2616]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2586]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 806]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 881]
js_SetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2616]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2586]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 806]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 881]
js_SetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2616]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2586]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 806]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 881]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3426]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1019]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 182]
nsXBLPrototypeHandler::ExecuteHandler
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLPrototypeHandler.cpp, line 448]
nsXBLWindowHandler::WalkHandlersInternal
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLWindowHandler.cpp, line 312]
nsXBLWindowKeyHandler::WalkHandlers
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLWindowKeyHandler.cpp, line 183]
nsXBLWindowKeyHandler::KeyPress
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLWindowKeyHandler.cpp, line 199]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1663]
nsXULDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 2460]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3488]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3480]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3480]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3480]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3480]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3480]
(Reporter)

Updated

17 years ago
Keywords: crash

Comment 2

17 years ago
WFM 20020611 NS7 QT6 NT 5.1
Keywords: crash

Updated

17 years ago
Keywords: crash

Comment 3

17 years ago
can't repro..hmm. nt 4 0612 brnch build qktime6

Comment 4

17 years ago
tried on qktime 5. noticed onw thing..the movie resizes when I click on "click 
to play" ..plays just fine..and don't see a crash after opening a tab.
wfm !

Comment 5

17 years ago
by 'resizes' , I meant - becomes smaller in size...
(Reporter)

Comment 6

17 years ago
Peter said he was clicking on chrome to give the browser focus. When I tried
that I did not crash. I *have* to click on the web page, or highlight text on
the webpage.
interesting. i didn't crash using joseph's steps... however, i stopped playing
the qt movie, then started closing tabs (using ctrl+w)...and i crashed. not sure
if it's related (trace below, not much to see), or another bug.

tested using 2002.06.24.08 comm branch bits on win2k + qt 5.


Incident ID 7668755
Stack Signature QuickTimeStreaming.qtx + 0x5ea23 (0x62c2ea23) db509c6d
Product ID Gecko1.0
Build ID 2002062408
Trigger Time 2002-06-24 14:05:04
Platform Win32
Operating System Windows NT 5.0 build 2195
Module QuickTimeStreaming.qtx
URL visited crash closing tabs
User Comments
Trigger Reason Access violation
Source File Name
Trigger Line No.
Stack Trace
QuickTimeStreaming.qtx + 0x5ea23 (0x62c2ea23)
0x00080103

Comment 8

17 years ago
QuickTimeStreaming.qtx and qktimeInternetextras.qtx or something is qktime's 
problem. there's a bug filed already for that and qktime is coming out with a 
new release with this fix soon. hang in there
QA Contact: sairuh → pmac

Comment 9

16 years ago
Crash, critical.
Severity: normal → critical

Updated

16 years ago
Summary: Crash switching tabs while Quicktime plays. → Crash switching tabs while Quicktime plays [@ QuickTimeStreaming.qtx]

Comment 10

16 years ago
Mozilla 1.3, Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Quicktime Plug-in 6.0.2, Windows 98

I had one of the animatrix movies loaded, played about 75% of it & then paused
it. Opened a few more tabs and then switched back to the first tab that had the
QT movie paused. When I clicked the play button, mozilla blew. 

See TB19857720X
Unable to reproduce with Mozilla 1.7 Beta and the latest Firefox nightly build
on Windows XP with QuickTime Plug-in 6.5
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
Crash Signature: [@ QuickTimeStreaming.qtx]
You need to log in before you can comment on or make changes to this bug.