Closed Bug 1519346 Opened 4 years ago Closed 4 years ago

No longer able to read list of attachments on write window with screen reader since Thunderbird 60

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 69.0

People

(Reporter: foss, Unassigned)

References

Details

(Keywords: access, regression)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

  1. Open the NVDA screen reader on Windows or Orca screen reader on GNU/Linux or on accessiblity monitor
  2. Write a new mail
  3. Add two attachment to it
  4. Move the cursor to the attachment if it's not the case
  5. Move between attachments with arrow keys

Actual results:

The screen reader stays silent because Thunderbird no longer sending accessibility events so a blind person couldn't verify attachment list anymore.

Expected results:

The screen reader should read the current focused item as it was the case with Thunderbird 52.

After looking on the Accerciser linux accessibility there is no longer accessibility events via D-BUS to tell "I'm not this item" so the screen reader can't inform the user.

Keywords: access, regression

(In reply to Alex ARNAUD from comment #0)

After looking on the Accerciser linux accessibility there is no longer
accessibility events via D-BUS to tell "I'm not this item" so the screen
reader can't inform the user.

*Accerciser accessibility event monitor
*To tell "I'm on this item"

More effects of the attachment bucket rework.

Flags: needinfo?(bugzilla2007)
Flags: needinfo?(acelists)

I believe we've had this bug already and tried to do as much as we could (which may not be enough), so we should find the duplicate of this and check. I know nothing about accessibility events and I doubt that it's me who broke it. Maybe caused by replacing XUL elements as they become extinct. So unfortunately, I can't assist here.

(In reply to Alex ARNAUD from comment #0)

  1. Add two attachment to it
  2. Move the cursor to the attachment if it's not the case

In TB 60, after adding attachments, focus is always already on an attachment (so this step is not needed).
Interesting. In bug 1519328, reporter of this bug 1519346 does NOT like it that we now focus attachments after adding them. Here, he presents a workflow which involves focusing of attachments to act on them right after adding. So for the workflow of this bug 1519346, auto-focus seems helpful, somewhat against the other bug. Indeed there are a lot of scenarios where auto-focus on attachments after adding is helpful, e.g.:

  • check if the right files were added (number and names)
  • rename just added files
  • open just added files to double-check the content if it's the correct version of file etc. (I do that all the time)
  • reorder just added files (new feature in TB 60)
  1. Move between attachments with arrow keys

Actual results:

The screen reader stays silent because Thunderbird no longer sending accessibility events so a blind person couldn't verify attachment list anymore.

That's the real problem which is also underlying bug 1519328: The problem is not that focus follows the action of adding attachments, but that screenreaders get disoriented when they are in attachment pane because the pane and/or its children don't communicate correctly. (I don't have time to test, but I believe that it does happen).

Flags: needinfo?(bugzilla2007)
Blocks: 1519328

(In reply to Thomas D. (currently busy elsewhere) from comment #3)

In TB 60, after adding attachments, focus is always already on an attachment (so this step is not needed).
Interesting. In bug 1519328, reporter of this bug 1519346 does NOT like it that we now focus attachments after adding them. Here, he presents a workflow which involves focusing of attachments to act on them right after adding. So for the workflow of this bug 1519346, auto-focus seems helpful, somewhat against the other bug. Indeed there are a lot of scenarios where auto-

It is not contrary.

  • when a blind person adds an attached file to a message, it is really not easy for him/her to loose its localisation in his/her message body due to the movement of the caret from the message to the attached files area.
  • however, once finished his/her message, or at any desird time actually, the user may need to know the list of the attached files. In such case, while you just need to have a look on the list, a blind user needs to bring the caret in the list with shift-tab. When he does this, of course, he browses such list via arrow keys as the screen reader reads just one line per line (expected). And to get this browse possible (even if there is just one line), the blind person needs to have the information about the attached filename when bringing the caret/focus on the attachments list.

Hence 2 bugs: one because the automatic movement is really confusing; the other because having no feedback on the attached filenames when the user requests this via shift-tab then arrow key is worse, he does not know the files he attached and cannot check them.

focus on attachments after adding is helpful, e.g.:

  • check if the right files were added (number and names)
  • rename just added files
  • open just added files to double-check the content if it's the correct version of file etc. (I do that all the time)
  • reorder just added files (new feature in TB 60)

Right, but this to be done on-demande predictible action is confusing for a basic user coming from other mail clients.

  1. Move between attachments with arrow keys

Actual results:

The screen reader stays silent because Thunderbird no longer sending accessibility events so a blind person couldn't verify attachment list anymore.

That's the real problem which is also underlying bug 1519328: The problem is not that focus follows the action of adding attachments, but that screenreaders get disoriented when they are in attachment pane because the pane and/or its children don't communicate correctly. (I don't have time to test, but I believe that it does happen).

Regards

Hi,

In latest nightly, when I add an attach file, I can see its name. But if I add more than one file, no feedback from an assistive technology when I press arrow keys. Moreover, I no longer can remove the attached file.

Yes, many things are currently broken in the UI. Actually, Richard/Geoff, can you please take a look and file a separate bug for trunk.

Flags: needinfo?(richard.marti)
Flags: needinfo?(geoff)

Maybe this is because it's no more possible to navigate through the attachments with the cursor keys. I filed for this bug 1526811.

Depends on: 1526811
Flags: needinfo?(richard.marti)
Depends on: 1533360
Status: UNCONFIRMED → NEW
Component: Untriaged → Message Compose Window
Ever confirmed: true
Flags: needinfo?(geoff)
Flags: needinfo?(acelists)
Target Milestone: --- → Thunderbird 69.0
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.