All users were logged out of Bugzilla on October 13th, 2018

Clicked on a link: crash [@ BitsToMap]

VERIFIED DUPLICATE of bug 149645

Status

--
critical
VERIFIED DUPLICATE of bug 149645
17 years ago
16 years ago

People

(Reporter: neilio, Assigned: mikepinkerton)

Tracking

({crash})

Details

(crash signature, URL)

(Reporter)

Description

17 years ago
Please let me know if you want these "suddenly quit" console outputs here or
not. I got one today - clicked on a link and it brought Chimera down - it was
the "home" link on my personal site (nothing fancy, just a plain html href).
Here's the console output:

Date/Time:  2002-06-14 18:48:05 -0500
OS Version: 10.1.5 (Build 5S60)
Host:       thenew.ca

Command:    Navigator
PID:        715

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0xd52b0404

Thread 0 Crashed:
 #0   0x734feb40 in BitsToMap
 #1   0x73508194 in QDPlatformGlobalToLocal
 #2   0x731216e4 in GetMouse
 #3   0x00402798 in nsDragService::BuildDragRegion(nsIScriptableRegion *,
nsIDOMNode *, OpaqueRgnHandle *)
 #4   0x0040255c in nsDragService::InvokeDragSession(nsIDOMNode *,
nsISupportsArray *, nsIScriptableRegion *, unsigned int)
 #5   0x002d48d0 in nsContentAreaDragDrop::DragGesture(nsIDOMEvent *)
 #6   0x002079dc in nsEventListenerManager::HandleEvent(nsIPresContext *,
nsEvent *, nsIDOMEvent **, nsIDOMEventTarget *, unsigned int, nsEventStatus *)
 #7   0x0046597c in nsWindowRoot::HandleChromeEvent(nsIPresContext *, nsEvent *,
nsIDOMEvent **, unsigned int, nsEventStatus *)
 #8   0x00077088 in GlobalWindowImpl::HandleDOMEvent(nsIPresContext *, nsEvent
*, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #9   0x001de9c0 in nsDocument::HandleDOMEvent(nsIPresContext *, nsEvent *,
nsIDOMEvent **, unsigned int, nsEventStatus *)
 #10  0x0029f410 in nsGenericElement::HandleDOMEvent(nsIPresContext *, nsEvent
*, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #11  0x0029f410 in nsGenericElement::HandleDOMEvent(nsIPresContext *, nsEvent
*, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #12  0x0029f410 in nsGenericElement::HandleDOMEvent(nsIPresContext *, nsEvent
*, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #13  0x0029f410 in nsGenericElement::HandleDOMEvent(nsIPresContext *, nsEvent
*, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #14  0x0029f410 in nsGenericElement::HandleDOMEvent(nsIPresContext *, nsEvent
*, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #15  0x0029f410 in nsGenericElement::HandleDOMEvent(nsIPresContext *, nsEvent
*, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #16  0x0029f410 in nsGenericElement::HandleDOMEvent(nsIPresContext *, nsEvent
*, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #17  0x0029f410 in nsGenericElement::HandleDOMEvent(nsIPresContext *, nsEvent
*, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #18  0x002aa178 in nsGenericHTMLElement::HandleDOMEventForAnchors(nsIContent *,
nsIPresContext *, nsEvent *, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #19  0x002a5b14 in nsGenericDOMDataNode::HandleDOMEvent(nsIPresContext *,
nsEvent *, nsIDOMEvent **, unsigned int, nsEventStatus *)
 #20  0x0020c4c0 in nsEventStateManager::GenerateDragGesture(nsIPresContext *,
nsGUIEvent *)
 #21  0x00209ee8 in nsEventStateManager::PreHandleEvent(nsIPresContext *,
nsEvent *, nsIFrame *, nsEventStatus *, nsIView *)
 #22  0x003328a0 in PresShell::HandleEventInternal(nsEvent *, nsIView *,
unsigned int, nsEventStatus *)
 #23  0x00332764 in PresShell::HandleEvent(nsIView *, nsGUIEvent *,
nsEventStatus *, int, int &)
 #24  0x003e7848 in nsViewManager::HandleEvent(nsView *, nsGUIEvent *, int)
 #25  0x003e6d9c in nsViewManager::DispatchEvent(nsGUIEvent *, nsEventStatus *)
 #26  0x003f11d0 in HandleEvent(nsGUIEvent *)
 #27  0x003f5cd4 in nsChildView::DispatchEvent(nsGUIEvent *, nsEventStatus &)
 #28  0x003f5d68 in nsChildView::DispatchWindowEvent(nsGUIEvent &)
 #29  0x003f5e28 in nsChildView::DispatchMouseEvent(nsMouseEvent &)
 #30  0x003f71f0 in -[ChildView mouseDragged:]
 #31  0x70c1bf60 in -[NSWindow sendEvent:]
 #32  0x70b9479c in -[NSApplication sendEvent:]
 #33  0x70c23488 in -[NSApplication run]
 #34  0x70c91ed0 in NSApplicationMain
 #35  0x00002730 in _start
 #36  0x00002560 in start

Thread 1:
 #0   0x700252fc in select
 #1   0x00dbe758 in poll
 #2   0x00dbae70 in _pr_poll_with_poll
 #3   0x00151b3c in nsSocketTransportService::Run(void)
 #4   0x00e92874 in nsThread::Main(void *)
 #5   0x00dbc32c in _pt_root
 #6   0x7002054c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x00db7418 in PR_WaitCondVar
 #3   0x00132ccc in nsDNSService::DequeuePendingQ(void)
 #4   0x001326d4 in nsDNSService::Run(void)
 #5   0x00e92874 in nsThread::Main(void *)
 #6   0x00dbc32c in _pt_root
 #7   0x7002054c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x7003f2b8 in _pthread_cond_wait
 #3   0x00db71b4 in pt_TimedWait
 #4   0x00db742c in PR_WaitCondVar
 #5   0x00e962d4 in TimerThread::Run(void)
 #6   0x00e92874 in nsThread::Main(void *)
 #7   0x00dbc32c in _pt_root
 #8   0x7002054c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7086c34c in -[NSConditionLock lockWhenCondition:]
 #3   0x70ba1358 in -[NSUIHeartBeat _heartBeatThread:]
 #4   0x70842358 in forkThreadForFunction
 #5   0x7002054c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x00db7418 in PR_WaitCondVar
 #3   0x00e93994 in nsThreadPool::GetRequest(nsIThread *)
 #4   0x00e942e8 in nsThreadPoolRunnable::Run(void)
 #5   0x00e92874 in nsThread::Main(void *)
 #6   0x00dbc32c in _pt_root
 #7   0x7002054c in _pthread_body

Thread 6:
 #0   0x70000978 in mach_msg_overwrite_trap
 #1   0x70005a04 in mach_msg
 #2   0x70026a2c in _pthread_become_available
 #3   0x70026724 in pthread_exit
 #4   0x70020550 in _pthread_body

PPC Thread State:
  srr0: 0x734feb40 srr1: 0x0000f030                vrsave: 0x00000005
   xer: 0x00000020   lr: 0x73508194  ctr: 0x70000a30   mq: 0x00000000
    r0: 0x0000f240   r1: 0xbfffda90   r2: 0x6f035660   r3: 0x03f0ccd2
    r4: 0xbfffdbf4   r5: 0x00000350   r6: 0x00000000   r7: 0x00000000
    r8: 0xbfffda78   r9: 0xd52b0404  r10: 0x43993380  r11: 0x80003780
   r12: 0x70000a30  r13: 0x00000000  r14: 0x00000000  r15: 0xbfffdd0c
   r16: 0xbfffdd08  r17: 0xbfffdd18  r18: 0xbfffdda8  r19: 0xbfffde38
   r20: 0x008e3874  r21: 0xbfffdd10  r22: 0xbfffdd14  r23: 0x035ae570
   r24: 0xbfffdbd8  r25: 0x03f531a8  r26: 0x00000000  r27: 0x03deb8a8
   r28: 0xbfffdbe4  r29: 0x03f0ccd0  r30: 0xbfffdbf4  r31: 0x00402464

**********

Comment 1

17 years ago
Neil, what action resulted in the crash? Accessing [http://www.beatnikpad.com/]
and clicking "Home"? The Home text at that URL doesn't appear to be linked.
Severity: normal → critical
Keywords: crash
Summary: Clicked on a link: crash → Clicked on a link: crash [@ BitsToMap]
(Reporter)

Comment 2

17 years ago
Sorry - I was actually deeper in the site and clicked the "home" link. It's a
standard, plain-jane href, however, so I didn't think the link itself caused the
crash. Could it be something related to the mouse click itself and not what was
being clicked on? Just a non-Application programmer's guess...

Comment 3

17 years ago
hey cool, blowing up in drag and drop
->pinkerton
Assignee: saari → pinkerton

Comment 4

17 years ago
Reporter, could you specify exactly what steps you took and what pages you went
to before this crash happened?
(Assignee)

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 149645 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Crash Signature: [@ BitsToMap]
You need to log in before you can comment on or make changes to this bug.