Closed Bug 1519411 Opened 11 months ago Closed 10 months ago

(picture-caching) Corrupted/flickering blur of image/video loading animation on https://web.whatsapp.com

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: darkspirit, Assigned: gw)

References

(Blocks 1 open bug, )

Details

(Keywords: correctness, nightly-community, Whiteboard: [66b-qatriage-p2])

Attachments

(3 files)

Attached video 2019-01-11_16-03-16.mp4
No description provided.
OS: Linux → All
Hardware: x86_64 → All
Attached video 2019-01-16_22-39-17.mp4

mozregression --launch 1312db5d4959 --pref gfx.webrender.all:true gfx.webrender.picture-caching:true -a https://web.whatsapp.com

Latest m-c still has this picture caching issue when hovering videos.

Flags: needinfo?(gwatson)

When I open that URL here, it looks very different to me (and I don't see any obvious bugs). Maybe it's different per-region, or is there somewhere you can navigate to other than the main page?

Flags: needinfo?(gwatson)
Assignee: nobody → gwatson

Is this still visible with the current build? Would it be possible to capture the web page content or a smaller repro case - I can't repro it here, but suspect I'm seeing a different page being served based on being in a different region.

Flags: needinfo?(jan)
Attached video 2019-01-20 15-39-14.mp4

Win10, GTX1060, build 20190120094340 with gfx.webrender.debug.picture-caching;true.
Yes, still reproducible.

I tested multiple Tor exits like Russia, Seychelles, United States and WhatsApp always looked the same.
You need to log in using the QR code and send a video to a contact.

Flags: needinfo?(jan)

I managed to reproduce this, the following is a minimal test case:

<!DOCTYPE html>
<html lang="en">
    <head>
        <meta charset="utf-8">
        <style type="text/css">
        </style>
    </head>
    <body>
        <div id="anim" style="filter: blur(3px);">
            <img style="border: 3px solid red;" src="Downloads/img1.jpg" width=250 height=250>
            <!-- <div style="width: 250px; height: 250px; background: radial-gradient(red, blue);"></div> -->
            <p style="position: absolute; top: 100px; left: 100px;">Hi</p>
        </div>
    </body>
</html>

To reproduce the bug, click / select the text in the center of the blur region.

Duplicate of this bug: 1521763

Verified, comment 0 and comment 1 are fixed by bug 1522022. Thanks!

Status: NEW → RESOLVED
Closed: 10 months ago
Depends on: 1522022
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.