Closed Bug 151958 Opened 20 years ago Closed 20 years ago

Stop button works but ESC does not.

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 76495

People

(Reporter: u27431, Assigned: joki)

References

()

Details

I've hit this problem in the past, albeit rarely, but I got it just now
accessing a page which was clearly "Slashdotted".  Getting tired of waiting for
it to load, I hit the ESC key repeatedly and it did not stop.  Hitting the
"Stop" button worked fine.  I was able to do this repeatedly while the site was
overloaded.

Playing around more generally with sites loading normally, I can stop pages
loading reliably with the "Stop" button while the ESC key frequently does
nothing.  It seems as though ESC is often ignored.  Since I tend to use ESC
rather than "Stop", because it is much faster to reach, this behaviour is a
nuisance.

Is it possible that ESC is being ignored during the "pause to download before
rendering" I've read about in other bugs?

*** This bug has been marked as a duplicate of 76495 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
QA Contact: rakeshmishra → trix
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.