Preview of Themes is visible on other items in Add-ons Manager (about:addons)

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
normal
VERIFIED FIXED
6 months ago
2 months ago

People

(Reporter: Virtual, Assigned: mstriemer)

Tracking

({nightly-community, regression, reproducible})

66 Branch
mozilla66
x86_64
Windows 7
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65+ verified, firefox66+ verified)

Details

Attachments

(3 attachments)

Posted video Screencast.mp4

STR:

  1. Use some external Light Themes/Appearances/Personas not build in browser (like https://addons.mozilla.org/addon/virtualfox/ for example)
  2. Open Add-ons Manager (about:addons)
  3. Open Themes tab
  4. Open external Light Themes/Appearances/Personas
  5. Open other item
    and see that preview of Light Themes/Appearances/Personas is visible on other items
Summary: Preview of Light Themes/Appearances/Personas is visible on other items → Preview of Light Themes/Appearances/Personas is visible on other items in Add-ons Manager (about:addons)

Assuming LWT, migration pending so wontfix.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WONTFIX
Flags: needinfo?(mstriemer)

This affects static themes as well, taking

Assignee: nobody → mstriemer
Flags: needinfo?(mstriemer)
Priority: -- → P1

Can reproduce on 65, but not 64.

Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de208c99e477
Explicitly clear theme preview on details for non-themes r=aswan
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0aba112c5ad9
Clear theme preview for themes that don't have previews r=aswan

Please nominate this for Beta approval when you get a chance. The final Beta build is being created on Thursday.

Flags: qe-verify+
Flags: needinfo?(mstriemer)
Status: REOPENED → RESOLVED
Closed: 6 months ago6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Summary: Preview of Light Themes/Appearances/Personas is visible on other items in Add-ons Manager (about:addons) → Preview of Themes is visible on other items in Add-ons Manager (about:addons)

I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 66.0a1 (2019-01-16), so I'm marking this bug as VERIFIED.
Thank you very much! \o/

Status: RESOLVED → VERIFIED

Comment on attachment 9036678 [details]
Bug 1519616 - Explicitly clear theme preview on details for non-themes r?aswan

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1506987

User impact if declined: After viewing a theme detail page, its preview image will be shown on other detail pages.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: 1. View the detail page for a theme
2. View the detail page for a plugin or extension

Expected: There is no preview image
Actual: There is a preview for the theme from step 1

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It is covered by automated tests and just clears an image src on load, before adding it for themes.

String changes made/needed:

Attachment #9036678 - Flags: approval-mozilla-beta?

Comment on attachment 9036698 [details]
Bug 1519616 - Clear theme preview for themes that don't have previews r?aswan

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: See other patch, both are required.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce:

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky):

String changes made/needed:

Flags: needinfo?(mstriemer)
Attachment #9036698 - Flags: approval-mozilla-beta?

Comment on attachment 9036678 [details]
Bug 1519616 - Explicitly clear theme preview on details for non-themes r?aswan

[Triage Comment]
Fixes a kinda-funny regression with theme previews in about:addons. Verified on Nightly and new tests added. Approved for 65.0b12.

Attachment #9036678 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9036698 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I successfully reproduced the issue on Firefox 66.0a1 (2019-01-12) under Windows 7 (x64) using the STR from Comment 0.

The issue is no longer reproducible on Firefox Beta 65.0b12 (20190116191407). Tests were performed under Windows 7 (x64), Ubuntu 18.04 (x64) and macOS 10.12.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.