Error console broken on TB trunk: Tools > Developer Tools > Error console

VERIFIED FIXED in Thunderbird 66.0

Status

defect
VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: jorgk, Assigned: darktrojan)

Tracking

({regression})

Trunk
Thunderbird 66.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

5 months ago

JavaScript error: resource://devtools/shared/base-loader.js, line 195: Error: Module devtools/server/actors/worker/worker-list is not found at resource://devtools/server/actors/worker/worker-list.js

Geoff, could you please take a look.

Flags: needinfo?(geoff)
Assignee

Comment 1

4 months ago
Posted patch 1519625-worker-list-1.diff (obsolete) — Splinter Review

I can't confirm this is working as my tree isn't in a fit state, but it looks like the right thing to do based on https://hg.mozilla.org/mozilla-central/rev/2ecae1ee43a0.

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(geoff)
Attachment #9036231 - Flags: review?(jorgk)

Comment 2

4 months ago

Thanks, it does not fully work (console does not open), but it changes the state and now I get:
console.error: (new TypeError("ServiceWorkerRegistrationActorList is not a constructor", "resource:///modules/tb-root-actor.js", 34))

Reporter

Comment 3

4 months ago

Nice, but even better without copy/paste errors ;-)

Attachment #9036231 - Attachment is obsolete: true
Attachment #9036231 - Flags: review?(jorgk)
Attachment #9036236 - Flags: review+

Comment 4

4 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/f9b760462530
Fix error console after bug 1510654. r=jorgk DONTBUILD

Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Reporter

Updated

4 months ago
Target Milestone: --- → Thunderbird 66.0

Comment 5

4 months ago

Yes this works for me, thanks.

Status: RESOLVED → VERIFIED
Keywords: regression
OS: Unspecified → All
Hardware: Unspecified → All
Version: unspecified → Trunk
Duplicate of this bug: 1521045
You need to log in before you can comment on or make changes to this bug.