Missing languages in Thunderbird's spelling preferences

RESOLVED FIXED in Thunderbird 66.0

Status

defect
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: aceman, Assigned: jorgk)

Tracking

({regression})

Trunk
Thunderbird 66.0
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Just opening preferences tab I see this in console:
JavaScript strict warning: chrome://messenger/content/preferences/compose.js, line 176: ReferenceError: reference to undefined property "label"

And indeed, on the Composition->Spelling tab the Language menulist only offers an "undefined" item.

The failing code is (last line):
var inlineSpellChecker = new InlineSpellChecker();
var sortedList = inlineSpellChecker.sortDictionaryList(dictList);

// Remove any languages from the list.
languageMenuList.removeAllItems();
  
// append the dictionaries to the menu list...
for (var i = 0; i < count; i++)
  languageMenuList.appendItem(sortedList[i].label, sortedList[i].id);

I do have 2 dictionaries installed, one of which is enabled.

Certainly from this change with I noticed looking at merged changesets:
8d5e2931f526 Zibi Braniecki — Bug 1509583 - Move InlineSpellChecker to sync over locale codes rather than indexes. r=Felipe
https://hg.mozilla.org/mozilla-central/rev/8d5e2931f526

Assignee: nobody → jorgk
Status: NEW → ASSIGNED

If you want to add more dictionaries to test, you must get them from AMO which serves WebExtension dictionaries, the only ones that will work on trunk; do not get them from ATN which still serves the old type.

This patch covers all call sites where the result of sortDictionaryList() is precessed.

Attachment #9036141 - Flags: review?(acelists)
Comment on attachment 9036141 [details] [diff] [review]
1519640-sorted-dict.patch

Review of attachment 9036141 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, this displays at least English (United States) as the only available language.
The other dictionaries are not listed, maybe for the reason you mention.
Attachment #9036141 - Flags: review?(acelists) → review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/1275fb1bcae3
Port bug 1509583: sorted dictionary list now uses localeCode/displayName instead of id/label. r=aceman

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 66.0
You need to log in before you can comment on or make changes to this bug.