Closed Bug 1519677 Opened 10 months ago Closed 10 months ago

Desktop site pages on Android can't be zoomed out all the way after zooming in

Categories

(Core :: Panning and Zooming, defect, P3)

66 Branch
All
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1508177
Tracking Status
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- affected

People

(Reporter: csheany, Unassigned)

Details

(Whiteboard: [geckoview:fenix:p3])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Android 7.1.1; Tablet; rv:66.0) Gecko/66.0 Firefox/66.0

Steps to reproduce:

  1. Open github.com/mozilla-mobile/focus-android
  2. Request desktop site
  3. Tap on Issues
  4. Open a link
  5. Zoom in

Actual results:

Zooming out stops at a certain point

Expected results:

The page can be fully zoomed out

Hi, thanks for your report.
I tried this issue on the latest version of Nightly (2019-01-13) Beta(65.0b9) and Release (64.0.2) and I can confirm it.
Device:

  • HTC 10 (Android 8.0.0);
  • Nexus 6P (Android 8.1.0);
  • Sony Xperia Z2 (Android 6.0.1).

Notes:
-Not reproducible on Chrome.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Android
Hardware: Unspecified → ARM

Oana, can your team test this on Focus? If it is affected, please add [geckoview] to the whiteboard field. Thanks!

Flags: needinfo?(oana.horvath)
Flags: needinfo?(oana.horvath)
Whiteboard: [geckoview]
Component: General → Panning and Zooming
Product: Firefox for Android → Core
Hardware: ARM → All
Version: Firefox 66 → 66 Branch

Oana, did you attach the right screenshot? It seems to be showing a phone's app switcher view.

Flags: needinfo?(oana.horvath)

Charles, do you see this issue in the 2019-01-16 nightly? Bug 1423013 may have affected (hopefully, fixed!) the behaviour here.

If you still see the issue with the 2019-01-16 nightly, could you provide the following additional information:

  • A link to a specific GitHub issue page where you're seeing this. (I ask for this because the height of the page matters, and that will vary based on how many comments the issue has.)
  • A screenshot in the zoomed-out state (or alternatively a description of e.g. what portion of the black top bar is visible in this state).

It seems fixed to a degree.

I was noticing it in particular here:

github.com/mozilla-mobile/focus-android/issues/4125

However I still experience a similar issue here

github.com/mozilla-mobile/fenix

(In reply to Botond Ballo [:botond] from comment #4)

Oana, did you attach the right screenshot? It seems to be showing a phone's app switcher view.

Yes :D I made it so the difference between Chrome's and Focus' zoom is visible. Probably not the best approach :)

Flags: needinfo?(oana.horvath)

(In reply to Oana Horvath from comment #7)

(In reply to Botond Ballo [:botond] from comment #4)

Oana, did you attach the right screenshot? It seems to be showing a phone's app switcher view.

Yes :D I made it so the difference between Chrome's and Focus' zoom is visible. Probably not the best approach :)

Ok. I'm still a bit confused, though:

  • The screenshot is showing a different site than the one from comment 0.
  • Both apps in the screenshot show content being really zoomed in (Chrome even more than Firefox!), while this bug about the minimum zoom level. Surely, neither Firefox nor Chrome in that screenshot are at their minimum zoom.

P3 for now because this zoom problem only affects desktop sites.

Priority: -- → P3
Summary: Pages can't be zoomed out to default → Desktop site pages on Android can't be zoomed out all the way after zooming in
Whiteboard: [geckoview] → [geckoview:fenix:p3]

Not reproducing on any page. I could repro for e.g. on github.com/mozilla-mobile/focus-android/issues/4141 but not on github.com/mozilla-mobile/focus-android/issues/4166
Load the issues list, switch to desktop mode on this page.
Zoom in the issues list.
Tap and open one of the links. Try to zoom out the issue page.

Ok, I think I understand now: in the screenshot in comment 10, on the right side, the page is zoomed out such that you can almost fit the entire width onto the screen, but not quite. There is a small amount of horizontal scroll range, maybe 10 or 20 pixels, that remains.

This has to do with the height of the page. It happens for shorter issue pages like #4141, and not for longer ones like #4166.

The reason the shorter issue page cannot be zoomed out further, is because there is no more content to show vertically, and we don't allow zooming out so much that we would show "blank" areas (areas with no page content).

This is a known issue, tracked in bug 1508177. I'm going to close this as a dupe.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1508177
You need to log in before you can comment on or make changes to this bug.