Closed Bug 1519764 Opened 2 years ago Closed 2 years ago

Disable dark theme for Pocket:Newtab

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 66
Iteration:
66.4 - Jan 21 - 27
Tracking Status
firefox66 --- fixed

People

(Reporter: dmose, Assigned: pdahiya)

References

Details

(Keywords: github-merged)

Attachments

(1 file)

Since we don't have plans to QA all the experiments with dark themes, we should disable it.

Can you target dark theme users for tests so they don't get included at all?

:mythmon - can we target non-dark-mode users in an experiment?

Flags: needinfo?(mcooper)

That depends on how users select dark mode. I suspect the most appropriate way to target users here would be by preference. Is dark mode controlled by a preference?

Flags: needinfo?(mcooper)
Iteration: --- → 66.4 - Jan 21 - 27
Priority: -- → P2
Summary: disable dark theme for Pocket:Newtab → Disable dark theme for Pocket:Newtab

Dark mode seems to be controlled by "lightweightThemes.selectedThemeID". Setting the dark theme will change this pref to "firefox-compact-dark@mozilla.org".

However, there is the problem of an OS dark theme which we support. And which ignores this pref and sets dark mode automatically even if the pref is set to its default value.

We might be better off trying to support dark theme than to try and find a way to not expose dark theme users to these experiments.

Assignee: nobody → pdahiya
Priority: P2 → P1

Hi Michael

Is it possible to exclude users with preference 'lightweightThemes.selectedThemeID' as 'firefox-compact-dark@mozilla.org' for NewTab experiment a) at the time of enrollment and b) during the experiment?

Your feedback here will help figure out the possible solutions and scope of work needed to handle FF and OS dark themes.

Thanks!

Flags: needinfo?(mcooper)

In short, yes, the experiment can do those things.

Normandy can make sure that any user that it enrolls in the study doesn't already have that pref set. Additionally, it will periodically check that the users continue to not have that pref set. If during a periodic check, Normandy finds the user has the preference set, it will unenroll the user from the experiment.

This is done by making that property part of the filter expression, which is used to select the users in the experiment.

Flags: needinfo?(mcooper)
Keywords: github-merged

How to test:

a) FF Dark Theme

  • Go to about:addons -> Themes -> Select Dark Theme
  • Open New Tab. It should open in dark mode
  • go to about:config
  • search for discoverystream.config and set preference enabled value as true
  • Navigate back to new tab or open a new tab. With discovery steam enabled new tab should not open in dark mode
  • Reset discoverystream.config to default with enabled as false, new tab should show in dark mode

b) OS Dark Mode

  • Select dark mode at OS level (Mac OS 10.14, Windows 10)
  • Open New tab in Nightly, it should open in dark mode
  • go to about:config
  • search for discoverystream.config and set preference enabled value as true
  • Navigate back to new tab or open a new tab. With discovery steam enabled new tab should not open in dark mode
  • Reset discoverystream.config to default with enabled as false, new tab should show in dark mode
Blocks: 1522752
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66

NI Brahmini for helping QA this fix. Thanks!

Flags: needinfo?(bnagabandi)

QA Note :

a) FF Dark Theme

  • Looks like this bug needs to be re-tested on discoverystream.config pref ?

Tested on :

FF Nightly version : 67.0a1 (2019-02-10)
OS : Mac and Windows 10 Pro

My observation is discoverystream.config pref has default enabled value as true which is incorrect, Results are seen as expected per QA steps.

QA Recording : https://www.dropbox.com/s/u2ln2m47us499ad/QA%20Results%20%28%3F%29%20-%20bug%201519764.mp4?dl=0

Mac OS :

  • When Dark Theme is enabled, if New Tab is refreshed, page flickers white background for micro second before Dark Theme adjusts.

QA Recording : https://www.dropbox.com/s/8nfb6ahgo34k3s1/QA%20Rec%20-%20bug%201519764%20%28Dark%20theme%20refresh%29.mp4?dl=0

Windows 10 Pro:

  • When Dark Theme is enabled, if New Tab is refreshed, page flickers white background for micro second before Dark Theme adjusts.
  • Same happens when a card is selected from new tab and then clicks back from Article to go back to New tab.

b) OS Dark Mode
Question : Do I need to have Mac OS 10.14? My current OS is 10.13.6, can you please confirm

Flags: needinfo?(bnagabandi) → needinfo?(pdahiya)

(In reply to Brahmini Nagabandi from comment #12)

QA Note :

a) FF Dark Theme

  • Looks like this bug needs to be re-tested on discoverystream.config pref ?

Tested on :

FF Nightly version : 67.0a1 (2019-02-10)
OS : Mac and Windows 10 Pro

My observation is discoverystream.config pref has default enabled value as true which is incorrect, Results are seen as expected per QA steps.

QA Recording : https://www.dropbox.com/s/u2ln2m47us499ad/QA%20Results%20%28%3F%29%20-%20bug%201519764.mp4?dl=0

That's expected. With Bug 1523703, discovery stream experience is turned on my default in nightly. It shouldn't be turned on by default in beta.

Mac OS :

  • When Dark Theme is enabled, if New Tab is refreshed, page flickers white background for micro second before Dark Theme adjusts.

My understanding this isn't a regression and micro seconds flicker is seen in default activity stream experience on new tab. Can you please verify. Thanks

QA Recording : https://www.dropbox.com/s/8nfb6ahgo34k3s1/QA%20Rec%20-%20bug%201519764%20%28Dark%20theme%20refresh%29.mp4?dl=0

Windows 10 Pro:

  • When Dark Theme is enabled, if New Tab is refreshed, page flickers white background for micro second before Dark Theme adjusts.
  • Same happens when a card is selected from new tab and then clicks back from Article to go back to New tab.

Same as above and should not be a regression. Can you please verify. Thanks

b) OS Dark Mode
Question : Do I need to have Mac OS 10.14? My current OS is 10.13.6, can you please confirm

Yes, OS Dark Mode switch is supported from 10.14 onwards

Flags: needinfo?(pdahiya) → needinfo?(bnagabandi)

Punam - Thanks for the updates, will verify them and I also need to do update Mac OS. Probably will need some time to test this bug.

Flags: needinfo?(bnagabandi)
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.