Closed Bug 1519766 Opened 10 months ago Closed 10 months ago

stand up basic list component

Categories

(Firefox :: New Tab Page, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 66
Iteration:
66.3 - Jan 7 - 20
Tracking Status
firefox66 --- fixed

People

(Reporter: dmose, Assigned: dmose)

References

()

Details

(Keywords: github-merged)

User Story

How to test:

    go to about:config
    search for stream.config
    set that preference to {"enabled":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=40249-e88c401e1b1f2242d9e441c4&layout_variant=dev-test-all"}
    open a new tab

The first "Trending Stories" list is the thing to look at.

Known bugs are already captured as dependents of the ds-list-component bug: https://bugzilla.mozilla.org/showdependencytree.cgi?id=1514020&hide_resolved=0
No description provided.
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/6967f2e7a0402133c93b82997b280e3ab1d99ffb
Bug 1519766 - basic List component for DiscoveryStream (WIP), r=thecount (#4654)
User Story: (updated)
Keywords: github-merged
Blocks: 1520691
Depends on: 1520854
User Story: (updated)
Duplicate of this bug: 1519771
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66

QA Results:

Tested on :

FF Nightly version : 66.0a1 (2019-01-18)

OS : Mac and Windows 10

Below are the observations :

  • New tab renders different layout with pref changes.
  • Trending stories section is seen.

Closing bug as verified.

Thanks,
Brahmini

Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.