Closed Bug 1519882 Opened 3 years ago Closed 1 year ago

Crash in nsSoundProxy::Init

Categories

(Core :: Widget: Win32, defect, P3)

x86_64
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox64 --- wontfix
firefox65 --- affected
firefox66 --- affected
firefox67 --- affected

People

(Reporter: alice0775, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-2251238b-40f8-46f0-bd13-deac00190114.

Top 10 frames of crashing thread:

0 xul.dll nsSoundProxy::Init widget/nsSoundProxy.cpp:45
1 xul.dll nsresult nsTypeAheadFind::PrefsReset toolkit/components/typeaheadfind/nsTypeAheadFind.cpp:169
2 xul.dll nsTypeAheadFind::Init toolkit/components/typeaheadfind/nsTypeAheadFind.cpp:121
3 xul.dll XPTC__InvokebyIndex xpcom/reflect/xptcall/md/win32/xptcinvoke_asm_x86_64.asm:97
4 @0x1f4d374e18f
5 xul.dll trunc
6 xul.dll trunc
7 xul.dll trunc
8 xul.dll static bool XPCWrappedNative::CallMethod js/xpconnect/src/XPCWrappedNative.cpp:1153
9 xul.dll static bool XPC_WN_CallMethod js/xpconnect/src/XPCWrappedNativeJSOps.cpp:946

=============================================================

STR: see Bug 1482659 comment 24

I see a few Mac crashes in 67.0b1 with this signature. The stack looks very similar to Windows.

Priority: -- → P3

This crash can be reproduced by changing the value of the preference 'accessibility.typeaheadfind.soundURL' to either some url or to 'default', then trying to find some text on a page that doesn't exist.

The typeaheadfind component tries to play sound from the child process when the find text is not found, yet there is an assertion in nsSoundProxy::Init that fails.

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.