[Linux PPC, French kbd] Alt-arrow and Alt-Home do nothing

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: vincent-moz, Assigned: akkzilla)

Tracking

({helpwanted})

Trunk
Future
PowerPC
Linux
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.1a) Gecko/20020612
BuildID:    2002061205

When hitting Alt-Left arrow, Alt-right arrow or Alt-Home, nothing happens.

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla.
2. Make sure that the current URL isn't the home URL.
3. Hit Alt-Home.

Actual Results:  Nothing happens.

Expected Results:  The home URL should have been opened.

I don't know what is the definition of the Alt key, but with my current XWindow
configuration (after defining the key as the mod1 key), it does work to select
parts of link text, so I assume that the Alt key is working.
Clicking on Home (in the menu) opens the home URL.

Comment 1

16 years ago
wfm on linux ppc..

Seems like you didn't configure your keyboard correct..

- Does ALT work in other applications?
On my iBook2 i need:
  xmodmap -e "keycode 115 = Mode_switch"
to get ALT working.. (the keycode may be different on a other mac..)

- Do you have a FN key? (laptop keyboard)
Make sure to press ALT+FN+Home.. FN+ALT+Home doesn't work (means: you'll have to
press ALT first..)
(Reporter)

Comment 2

16 years ago
> - Does ALT work in other applications?

The other applications don't use the Alt key. They use either Meta or
Mode_switch (no problem with them). On my keyboard, the physical Alt key is
bound to Mode_switch.

> - Do you have a FN key? (laptop keyboard)

Yes, this is a French (AZERTY) Titanium keyboard. ALT+FN+Home doesn't do
anything, probably because ALT must be accessed via FN (hitting the option key
without FN is equivalent to click with the right button of the mouse).

Anyway, according to the selection of link text feature, the Meta key is here
equivalent to the Alt key, but I don't understand why it doesn't work with
Alt+Home and so on. This is the bug.

Comment 3

16 years ago
Akkana, do you know who should own this Linux on PPC bug?
Assignee: aaronl → akkana
Summary: Alt-arrow and Alt-Home do nothing → [Linux PPC, French kbd] Alt-arrow and Alt-Home do nothing
(Assignee)

Comment 4

16 years ago
I doubt that meta and alt should be equivalent on linux PPC.  They aren't on any
other platform (like linux i386 or mac).  On mac, meta=command and alt=alt, and
that's probably a reasonable mapping for linux PPC too.

It sounds like it may be a keymapping issue on the reporter's machine, if it
works on other linux PPC boxes -- perhaps you're just not mapping the alt key
correctly.  I can't test it myself to confirm, since I don't have access to a
linux PPC box (this really should be owned by someone who does, but
unfortunately I don't know of any moz developers who currently have linux ppc).
Keywords: helpwanted
Target Milestone: --- → Future

Comment 5

16 years ago
This is the keyboard:
[FN][CTRL][ALT][APPLE][ -- Space --][APPLE]
            ^     ^--------------------^---- Both have Keycode 115
            |------------------------------- Has keycode 64

keycode 115 = Mode_switch   aka Alt GR
keycode 64 = Alt_L Meta_L
..does a 'xmodmap -pke | grep " 64"' also say 'Alt_L Meta_L' on your machine?
If not, use xmodmap to set it correct..
Some PPC Keymaps are buggy..

It wfm on a Swiss German keyboard.. it also Works for two PPC Linux users i
know, they have both a normal German keyboard layout..

Does 'ALT+<-' also not work?
(Reporter)

Comment 6

16 years ago
My Titanium keyboard has:
  [FN][CTRL][OPTION][APPLE][-- Space --][SPECIAL][OPTION]
and Fn-Option is Alt (Alt is written in italic above the Option key). Both
Option keys give the same keycode (I've been told that one can't change that, a
hardware limitation?), but Special and Apple have different keycodes.

As the Titanium trackpad has only one button, I had to choose two keys for the
other two mouse buttons. I couldn't choose function keys, because I already use
all of them for the French accented characters (on any keyboard -- this is what
I and other people have been using for years), so I chose Special and Option
being the other two mouse buttons.

I needed a Meta key (for xterm in particular, but it also used by other
applications), so Apple = Meta key, which has keycode 115. I also needed an
AltGr key (for special character), called Mode_switch under XWindow, so Alt
(Fn-Option) = AltGr key, which has keycode 113.

Keycode 64 is Alt_L on my machine, but this keycode is taken by the right mouse
button.

Comment 1 of bug 135410 says that the Alt key is the key used to select a part
of a link, and this is exactly what the Meta key does here. If Mozilla is
consistent, the Meta key should also work to open the home URL with Meta-Home,
but it doesn't.

I've just seen that Ctrl gives keycode 37 (Control_L) and Fn-Ctrl gives keycode
109 (Control_R), and as Control_R isn't used in practice, I could use xmodmap to
have Fn-Ctrl = Alt_L (hoping that this will work in Mozilla), but I'd prefer if
the Meta key worked. This is either a bug concerning Alt-Home/... or a
consistency problem that should be solved.
(Reporter)

Comment 7

16 years ago
mod4 was set to Meta_L (this is the system default here) and using

  xmodmap -e "clear mod4"

solves all the problems (well, some applications need to be restarted after the
change, though). Now I can use the Meta key for selecting a part of link text
and for the Back, Forward and Home operations in Mozilla.

It seems that the code to select a part of link text looks for the keyboard
state, ANDs it with 0x8 (0x8 is for mod1) and if the result is nonzero, the text
selection is used instead of URL drag'n-drop. Concerning the Back, Forward and
Home operations, it seems that Mozilla requires that the keyboard state is
exactly 0x8 (0x48 was given with my previous configuration, 0x40 corresponding
to mod4) because several modifiers may be used for different functions.

IMHO, Mozilla should be clearer concerning what it requires. For instance, if
Meta is used for mod1, then Mozilla should write "Meta+Home" instead of
"Alt+Home" in the menu. I don't know if a new bug should be open concerning that
point (and this bug closed) or something else...
(Assignee)

Comment 8

16 years ago
I'm going to close this one as WORKSFORME, since it's an issue with the X
keyboard  map.

It's hard to know how to be clear in a way that will cover all possible xmodmaps
-- on i386 linux, too, we have this problem, since some distros ship with
different modifier key mappings (Debian, Mandrake and Redhat are all a little
different) and then of course international keyboard mappings further complicate
things.

I wish I had a good idea for a unified strategy which would make this all clear
for everyone -- I'm certainly open to suggestions.

Also, if anyone understands the issue well enough to be able to write up an
explanation which would make it clearer to other linux users, please send it to
me and I'll put it on mozilla.org.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.