Closed Bug 1520193 Opened 2 years ago Closed 2 years ago

toolkit/xre/nsXREDirProvider.cpp:22:10: fatal error: commonupdatedir.h: No such file or directory

Categories

(Toolkit :: Startup and Profile System, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1520131
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: jbeich, Unassigned)

Details

(Keywords: regression)

Downstream may install Firefox in a system-wide locations owned by root where self-updating is undesirable. Some bundled extensions also want to know update channel to derive rollout strategy.

$ c++ -v
FreeBSD clang version 7.0.1 (tags/RELEASE_701/final 349250) (based on LLVM 7.0.1)
Target: x86_64-unknown-freebsd13.0
Thread model: posix
InstalledDir: /usr/bin

$ echo "ac_add_options --disable-updater" >>.mozconfig
$ ./mach bootstrap
$ ./mach build
[...]
In file included from objdir/toolkit/xre/Unified_cpp_toolkit_xre0.cpp:137:
toolkit/xre/nsXREDirProvider.cpp:22:10: fatal error: 'commonupdatedir.h' file not found
#include "commonupdatedir.h"
^~~~~~~~~~~~~~~~~~~
1 error generated.

Removing the include line unbreaks my build and passes --enable-warnings-as-errors. However, without understanding WHY it'd be incorrect to guard via #ifdef MOZ_UPDATER.

Oops, I didn't notice someone else reported the same issue a few hours prior.

No longer blocks: 1518587
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1520131
You need to log in before you can comment on or make changes to this bug.