Closed Bug 1520221 Opened 2 years ago Closed 2 years ago

Avoid wrapping markdown comments

Categories

(bugzilla.mozilla.org :: Email Notifications, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: dholbert, Assigned: dylan)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

For some reason, bugmail for treeherder intermittent-failure bugs like bug 1520030 generates <h1> styling around the initial text in bugmail, but not in the actual bugzilla UI.

The bug's first comment looks roughly fine on bugzilla (no <h1> tags), but the bugmail has huge text (and does have an <h1>).

See attached screenshot.

EXPECTED RESULTS:

  • Consistent HTML should be generated in bugmail as in a bug comment.
  • Once we can figure out what bit of markdown is making the text huge in bugmail (if that's not just a bug itself), then we can update the treeherder-intermittent-bug template text to avoid doing that.

(The symptom here is kinda similar to bug 1518576, except that one had huge h1-styled text in both bugmail and in the actual bug. Whereas in this bug here, only bugmail is affected, which makes it seem likely that something's broken.)

Blocks: bmo-markdown
Component: General → Email Notifications

For reference, here's some of what I see if I do "view source" on the bugmail (from the start of the html block until a little ways into the giant h1 section): https://bugzilla.mozilla.org/attachment.cgi?id=9036636

So the underlying issue here is really weird. I'm assuming something happens to line endings before the content is passed to renderMarkdown() when generating the email. I think it may be best to skip markdown rendering for emails and just send them out as <pre> content.

Thoughts, kohei?

Assignee: nobody → dylan
Flags: needinfo?(kohei.yoshino)

This part is simple. I think there may be already another bug for the treeherder escaping stuff to prevent markdown interpretation

This bug will just be about the wrapping which made the text become an h1 in the bugmail.
For the other problem of treeherder lines being interpreted as markdown, see bug 1519564

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
See Also: → 1519564
Summary: Huge h1 styling in bugmail (and only in bugmail!) for initial "NFO - REFTEST TEST-START" text in treeherder intermittent-failure bugs → Avoid wrapping markdown comments
Duplicate of this bug: 1520746
Flags: needinfo?(kohei.yoshino)
You need to log in before you can comment on or make changes to this bug.