Closed Bug 1520222 Opened 2 years ago Closed 2 years ago

layout.css.scroll-anchoring.enabled causes wild flickering on mail.google.com when a message input is open on macOS

Categories

(Core :: Layout, defect)

defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1519541
Tracking Status
firefox66 --- verified

People

(Reporter: nalexander, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

+++ This bug was initially created as a clone of Bug #1519462 +++

I've cloned Bug 1519462 'cuz I'm not certain that the issue is the same, although the fix addresses the issue.

When I reply to a message on mail.google.com (for my Mozilla gmail account), a message input pops up. Scrolling, generally to the top or bottom of the page, causes the content display to start jumping around and wildly flickering.

Setting layout.css.scroll-anchoring.enabled=false in about:config (and restarting the browser, although I don't know if that's relevant) returns gmail to normal.

I updated Nightly several times; latest is 20190115103851. I'm running macOS 10.14.2.

I think this is a duplicate of bug 1519541.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1519541

Nick, can you verify that this is fixed using today's night? If you don't have time, I can ask QA but since you hit the issue maybe you can just confirm.

Flags: needinfo?(nalexander)

(In reply to Liz Henry (:lizzard) (use needinfo) from comment #2)

Nick, can you verify that this is fixed using today's night? If you don't have time, I can ask QA but since you hit the issue maybe you can just confirm.

Yes, I can confirm this is fixed using Nightly 20190116093310. I installed the update, restarted, set the pref to default (true), restarted, and did not witness the behaviour in a gmail message.

Flags: needinfo?(nalexander)
You need to log in before you can comment on or make changes to this bug.