When apps use Chimera to open URL's Chimera opens 2 windows

VERIFIED FIXED in Chimera0.5

Status

Camino Graveyard
General
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Brian Lee, Assigned: Simon Fraser)

Tracking

unspecified
Chimera0.5
PowerPC
Mac OS X

Details

(Reporter)

Description

16 years ago
When apps like Microsoft Entourage try to pass Chimera a URL to open (because
for some reason OS X picked Chimera as default browser when I deleted IE)
Chimera opens 2 windows 1 for the actual URL that Entourage passed Chimera and
another that just blanks. I'm using OS X versoin 10.1.5 with Chimera 0.3.0
nightly build (6/14/2002).

Steps.
1) Try setting Chimera as the default browser if you still have IE around
2) Open a url that you recieved in an Email with Entourage or an app that
follows the OSX system preferences "Default browser".

Result.

1) Chimera will open the URL but also open a new browser window as well, I have
my default page set to about:blank it may or may not show your start page.
(Reporter)

Comment 1

16 years ago
Oh make sure you quit Chimera if you have it open already

Comment 2

16 years ago
->pinkerton
Assignee: saari → pinkerton
only at startup. this is because window opening is async. i can't tell from the
GURL handler if a new window is currently being created so i have to create a
new one.

help?
Target Milestone: --- → Chimera0.5
(Assignee)

Comment 4

16 years ago
Mine
Assignee: pinkerton → sfraser

Comment 5

16 years ago
For me, I selected Navigator as my default browser, and it doesn't load the URL
in the Window. Should we discuss that here or should I file a new bug?
ben, what build are you using? that was a known bug with the 0.3 release and the
nightlies right around that time period. should work ok now.

Comment 7

16 years ago
Confirmed using Chimera/20020625, but Mozilla does this, too. What's the right
thing to do here? See also bug 35578.
(Assignee)

Comment 8

16 years ago
The right thing is to follow the pref for opening URLs in new windows or new
tabs, while enriching the Apple Event API to allow scripters to control the
behaviour more precisely.
It looks like you still get 2 windows opened on launch in the
6-29 NB (if it's from a URL or open file request from another app,
that is).

Now, good news.  There's a patch in bug 155048 which fixes the
2 window on launch behavior, as well as a couple other things.

They were all just sort of in the same place, so it was tough
to break them apart.
Depends on: 155048
(Assignee)

Comment 10

16 years ago
I checked in the patch in bug 155048
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 11

16 years ago
Verified in 07-08 build on OS 10.1.5.  Verified the case of chimera already
launched before clicking on the URL from the external application, and the case
of chimera not launched yet before clicking on the URL.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.