Menu scroll buttons should appear only when it is possible to scroll in that direction

VERIFIED DUPLICATE of bug 76828

Status

SeaMonkey
Bookmarks & History
--
minor
VERIFIED DUPLICATE of bug 76828
16 years ago
13 years ago

People

(Reporter: Ariel Arjona, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a)
Gecko/20020613 MultiZilla/v1.1.15
BuildID:    2002061308

When there are more bookmarks in the folder than space available, scroll buttons
appear at the top and bottom of the bookmark menu.
However, if it is not possible to scroll up (we are at the top of the list for
example), there should be no scroll button there.

Reproducible: Always
Steps to Reproduce:
1.Fill a folder with a lot of bookmarks
2.display the folder clicking on any Bookmarks menu.


Actual Results:  scroll buttons appear at the top and bottom of the menu.

Expected Results:  there only should be a button at the bottom. The top button
should appear once there is something to scroll into. Also when we reach the
end, the bottom button should disappear.

The buttons not appearing until needed would be the best behavior IMO. This is
consistent with current bookmark behavior (the buttons are not there until there
are enough bookmarks to fill the screen).

However at the very least the buttons should be visibly disabled (grayed out or
whatever the standard is), when they are not needed.
(Reporter)

Comment 1

16 years ago
Created attachment 87792 [details]
Screenshot of bookmarks with the scroll button visible

Attached screenshot of the bookmarks menu with the scroll buttons even though
we are at the top of the list.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 76828 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Summary: Scroll buttons should appear only when it is possible to scroll in that direction → Menu scroll buttons should appear only when it is possible to scroll in that direction

Comment 3

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.