Fix facet-discrete animation on including and excluding an item.

RESOLVED FIXED in Thunderbird 66.0

Status

defect
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: arshad, Assigned: arshad)

Tracking

({regression})

Trunk
Thunderbird 66.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 4 obsolete attachments)

Assignee

Description

4 months ago
No description provided.
Assignee

Updated

4 months ago
Assignee: nobody → arshdkhn1
Status: NEW → ASSIGNED
Assignee

Updated

4 months ago
Keywords: regression
Assignee

Comment 1

4 months ago

The first include and exclude is normal, but any include/exclude after that doesn't end up in the right way.

Assignee

Comment 2

4 months ago
Attachment #9036933 - Flags: review?(mkmelin+mozilla)
Assignee

Comment 3

4 months ago
Attachment #9036933 - Attachment is obsolete: true
Attachment #9036933 - Flags: review?(mkmelin+mozilla)
Assignee

Comment 4

4 months ago
Attachment #9036944 - Attachment is obsolete: true
Attachment #9036948 - Flags: review?(mkmelin+mozilla)
Assignee

Comment 5

4 months ago

Apply this patch on top of patch from Bug 1520464.

Assignee

Updated

4 months ago
Attachment #9036948 - Flags: review?(mkmelin+mozilla) → review?(jorgk)

Comment 6

4 months ago
Comment on attachment 9036948 [details] [diff] [review]
facet-discrete-animation.patch

I'm trying to keep out of de-XBL and friends.

Comment should be:
  // Adding setTimeout to improve the facet-discrete animation.
  // See Bug 1439323 for more detail.
Attachment #9036948 - Flags: review?(jorgk) → review?(mkmelin+mozilla)
Assignee

Comment 7

4 months ago

(In reply to Jorg K (GMT+1) from comment #6)

Comment on attachment 9036948 [details] [diff] [review]
facet-discrete-animation.patch

I'm trying to keep out of de-XBL and friends.

Comment should be:
// Adding setTimeout to improve the facet-discrete animation.
// See Bug 1439323 for more detail.

Well it was just a timeout that tries to fix the racing condition.

Assignee

Comment 8

4 months ago
Attachment #9036948 - Attachment is obsolete: true
Attachment #9036948 - Flags: review?(mkmelin+mozilla)
Attachment #9037766 - Flags: review?(mkmelin+mozilla)
Assignee

Comment 9

4 months ago
Attachment #9037766 - Attachment is obsolete: true
Attachment #9037766 - Flags: review?(mkmelin+mozilla)

Updated

4 months ago
Duplicate of this bug: 1439323
Assignee

Updated

4 months ago
Attachment #9037767 - Flags: review?(mkmelin+mozilla)
Comment on attachment 9037767 [details] [diff] [review]
facet-discrete-animation.patch

Review of attachment 9037767 [details] [diff] [review]:
-----------------------------------------------------------------

Usually setTimeout is a hack, and perhaps it is here too. But this is a hack to make the UI look better and shouldn't cause problems elsewhere, so let's take it. r=mkmelin
Attachment #9037767 - Flags: review?(mkmelin+mozilla) → review+

Comment 12

4 months ago

On IRC Arshad told me that he had tried async/await somehow with no success.

Comment 13

4 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/9e7712f9a4d2
Fix facet-discrete animation. r=mkmelin

Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 14

4 months ago

Does this need beta uplift to TB 65 beta? What's the regressing bug?

Target Milestone: --- → Thunderbird 66.0
You need to log in before you can comment on or make changes to this bug.