Closed Bug 1520505 Opened 2 years ago Closed 1 year ago

Banner ad taking much longer to retrieve/render in Firefox than in Chrome

Categories

(Core :: Performance, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox66 --- affected

People

(Reporter: acreskey, Unassigned)

References

Details

(Whiteboard: [qf:p1:pageload])

When loading the following buzzfeed page we see that the banner ad appears in Firefox roughly 11 seconds after it does in Chrome.
Otherwise the page rendering is comparable (within a second) in each browser.

Site:
https://www.buzzfeed.com/daves4/the-new-york-times-makes-the-nerdiest-correction-e?utm_term=.tlL2KE08L6#.hwrBglaV2A

Filmstrip replay (comparing Firefox to Chrome on Moto G4)
https://www.webpagetest.org/video/compare.php?tests=190113_DA_9b8801efe5673acdd127a79ff812fcc4-r:1,190113_P2_5578faf79a7aa1617272123e889d550d

I've reproduced this scenario multiple times.
Sometimes different ads are served, however Chrome consistently renders them sooner.

On this particular page this delay affects the timing of the onLoadEvent.

Tested the same website on my Moto G5. I am able to see a gap, however, it is not as big as 11 seconds we see on Webpagetest. Fennec/Geckoview_example takes ~11 seconds to load the ad whereas Chrome Beta takes ~8 seconds.

Whiteboard: [qf]

We need some profile here. Somehow we trigger the image load before load event and I think Chrome triggers it afterwards.

That page is using fetch(), which we don't de-prioritize during page load yet
(https://bugzilla.mozilla.org/show_bug.cgi?id=1538516).

needinfo myself to capture new profiles.

Flags: needinfo?(acreskey)

Profile http://bit.ly/2TCvtIt, the banner image loaded around 19 seconds

Flags: needinfo?(acreskey)

It's very possible that this is caused by Bug 1529044 which has been improved and we're working on improving further.

Depends on: 1529044
Whiteboard: [qf] → [qf:p1:pageload]

Can you see if this is still an issue?

Flags: needinfo?(acreskey)

When I load this site the banner ad no longer appears in either geckoview_example or Chrome (instead the page animates up).

Since this can no longer be reproduced I'll close this.

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(acreskey)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.