Reduce the boilerplate around interners

RESOLVED FIXED in Firefox 66

Status

()

enhancement
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: bholley, Assigned: bholley)

Tracking

unspecified
mozilla66
Points:
---

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(4 attachments)

(Assignee)

Description

4 months ago

There's a lot of repeated code, which hampers velocity and increases the risk of bugs. I've got some patches to clean this up.

(Assignee)

Comment 3

4 months ago
Depends on D16779
(Assignee)

Comment 5

4 months ago

One last thing I didn't get to tonight was renaming DocumentResources->Interners and FrameResources->DataStores, which should improve clarity given that those things were removed from the member names. Let me know if that sounds good to you.

Flags: needinfo?(dglastonbury)
(Assignee)

Comment 6

4 months ago

(In reply to Bobby Holley (:bholley) from comment #5)

One last thing I didn't get to tonight was renaming DocumentResources->Interners and FrameResources->DataStores, which should improve clarity given that those things were removed from the member names. Let me know if that sounds good to you.

I've just gone ahead and done this in the latest patch.

Flags: needinfo?(dglastonbury)

Comment 8

4 months ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1d2ae392021c
Declare intern-related types in a structured way. r=kamidphish
https://hg.mozilla.org/integration/autoland/rev/5fa2f414676e
Use macros to reduce boilerplate. r=kamidphish
https://hg.mozilla.org/integration/autoland/rev/64717bf7f849
Simplify naming of interner and data_store instances. r=kamidphish
https://hg.mozilla.org/integration/autoland/rev/ad7c9c863c2e
Rename the *Resource* types to be more clearly about interning. r=kamidphish

Backed out 4 changesets (Bug 1520678) for build bustages complaining no field resources

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=ad7c9c863c2e6cb1711c4e8c0fc1057489dfe1e1

Backout link: Backed out 4 changesets (Bug 1520678) for build bustages complaining no field resources CLOSED TREE

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=222614385&repo=autoland&lineNumber=27765

01:55:33 INFO - [style 0.0.1] cargo:rerun-if-changed=z:/build/build/src/obj-firefox/dist\include\mozilla/ScrollStyles.h
01:55:33 INFO - [style 0.0.1] cargo:rerun-if-changed=z:/build/build/src/obj-firefox/dist\include\mozilla/EventClassList.h
01:55:33 INFO - Running z:/build/build/src/rustc/bin/rustc.exe --crate-name style 'servo\components\style\lib.rs' --color never --crate-type lib --emit=dep-info,link -C opt-level=2 -C panic=abort -C codegen-units=1 --cfg 'feature="bindgen"' --cfg 'feature="fallible"' --cfg 'feature="gecko"' --cfg 'feature="nsstring"' --cfg 'feature="regex"' --cfg 'feature="style_traits"' --cfg 'feature="toml"' --cfg 'feature="use_bindgen"' -C metadata=9519b9526883db44 -C extra-filename=-9519b9526883db44 --out-dir 'z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps' --target i686-pc-windows-msvc -L 'dependency=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps' -L 'dependency=z:/build/build/src/obj-firefox\release\deps' --extern 'app_units=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libapp_units-c090f6e457460f7a.rlib' --extern 'arrayvec=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libarrayvec-68576629d7a3a2d0.rlib' --extern 'atomic_refcell=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libatomic_refcell-701f67f55364427e.rlib' --extern 'bitflags=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libbitflags-903a48f521d1339a.rlib' --extern 'byteorder=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libbyteorder-59ce1c64327b935e.rlib' --extern 'cssparser=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libcssparser-a09454381ef253f9.rlib' --extern 'euclid=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libeuclid-541edd3a136187e2.rlib' --extern 'fallible=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libfallible-023cad764ec95b77.rlib' --extern 'fxhash=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libfxhash-4d13a25586fdfbb2.rlib' --extern 'hashglobe=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libhashglobe-f5007cbfb7829fbc.rlib' --extern 'indexmap=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libindexmap-588385a09a12d64f.rlib' --extern 'itertools=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libitertools-78d86d52bd0ae288.rlib' --extern 'itoa=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libitoa-55cf16941d4cec3a.rlib' --extern 'lazy_static=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\liblazy_static-0a59681ddeed70e4.rlib' --extern 'log=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\liblog-7997b142f01e9feb.rlib' --extern 'malloc_size_of=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libmalloc_size_of-e4c4befecdd76658.rlib' --extern 'malloc_size_of_derive=z:/build/build/src/obj-firefox\release\deps\malloc_size_of_derive-50fd03ce294d97e4.dll' --extern 'matches=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libmatches-e286b4d8d27f0d31.rlib' --extern 'debug_unreachable=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libdebug_unreachable-c6cb9899e62aa7c3.rlib' --extern 'nsstring=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libnsstring-3c6020dabab201fc.rlib' --extern 'num_derive=z:/build/build/src/obj-firefox\release\deps\num_derive-dd9db4f52ac5b923.dll' --extern 'num_integer=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libnum_integer-8c363068318671cd.rlib' --extern 'num_traits=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libnum_traits-7d0b2b115efd545e.rlib' --extern 'num_cpus=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libnum_cpus-0b633a2d07585be2.rlib' --extern 'ordered_float=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libordered_float-54f9af2f143fbd3d.rlib' --extern 'owning_ref=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libowning_ref-b3e7700363e9ed43.rlib' --extern 'parking_lot=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libparking_lot-9338efea3a3d4c02.rlib' --extern 'precomputed_hash=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libprecomputed_hash-289216524d668e88.rlib' --extern 'rayon=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\librayon-08f5439af5568384.rlib' --extern 'selectors=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libselectors-e9582412b6afce72.rlib' --extern 'servo_arc=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libservo_arc-e2301d9465235471.rlib' --extern 'smallbitvec=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libsmallbitvec-d19b09a1aab98ff5.rlib' --extern 'smallvec=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libsmallvec-237ef6bf5125e302.rlib' --extern 'style_derive=z:/build/build/src/obj-firefox\release\deps\style_derive-ed4fe5455ea27dbf.dll' --extern 'style_traits=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libstyle_traits-9a8fb3e717d5dc9f.rlib' --extern 'thin_slice=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libthin_slice-797a7597caf4256a.rlib' --extern 'time=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libtime-133b3f80cc2650a3.rlib' --extern 'uluru=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libuluru-41a2f7f0bc0479ab.rlib' --extern 'unicode_bidi=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libunicode_bidi-8c027a725863d50d.rlib' --extern 'unicode_segmentation=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libunicode_segmentation-480cbf602e4046bb.rlib' --extern 'void=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libvoid-7e2b4442c531d484.rlib' -C opt-level=2 -C debuginfo=2 -Dwarnings
01:55:33 INFO - Running z:/build/build/src/rustc/bin/rustc.exe --crate-name webrender 'gfx\wr\webrender\src\lib.rs' --color never --crate-type lib --emit=dep-info,link -C opt-level=2 -C panic=abort -C codegen-units=1 --cfg 'feature="capture"' --cfg 'feature="debug_renderer"' --cfg 'feature="ron"' --cfg 'feature="serde"' --cfg 'feature="serialize_program"' --cfg 'feature="webrender_api"' --cfg 'feature="webrender_build"' -C metadata=ace6f8174f505516 -C extra-filename=-ace6f8174f505516 --out-dir 'z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps' --target i686-pc-windows-msvc -L 'dependency=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps' -L 'dependency=z:/build/build/src/obj-firefox\release\deps' --extern 'app_units=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libapp_units-c090f6e457460f7a.rlib' --extern 'bincode=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libbincode-b688a9fce63efa4f.rlib' --extern 'bitflags=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libbitflags-903a48f521d1339a.rlib' --extern 'byteorder=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libbyteorder-59ce1c64327b935e.rlib' --extern 'cfg_if=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libcfg_if-a4ea9281d920b328.rlib' --extern 'dwrote=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libdwrote-1a469abaf11b1f0c.rlib' --extern 'fxhash=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libfxhash-4d13a25586fdfbb2.rlib' --extern 'gleam=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libgleam-8d9d2e529997f7c8.rlib' --extern 'lazy_static=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\liblazy_static-0a59681ddeed70e4.rlib' --extern 'log=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\liblog-7997b142f01e9feb.rlib' --extern 'malloc_size_of_derive=z:/build/build/src/obj-firefox\release\deps\malloc_size_of_derive-50fd03ce294d97e4.dll' --extern 'num_traits=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libnum_traits-7d0b2b115efd545e.rlib' --extern 'plane_split=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libplane_split-ec0507230ee8af02.rlib' --extern 'rayon=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\librayon-08f5439af5568384.rlib' --extern 'ron=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libron-f678f5a156975e65.rlib' --extern 'serde=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libserde-72281521555d1ae6.rlib' --extern 'sha2=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libsha2-d80f8598244aca59.rlib' --extern 'smallvec=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libsmallvec-237ef6bf5125e302.rlib' --extern 'thread_profiler=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libthread_profiler-5d8186d977e070fe.rlib' --extern 'time=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libtime-133b3f80cc2650a3.rlib' --extern 'webrender_api=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libwebrender_api-2bd0396cbe5b2e17.rlib' --extern 'webrender_build=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libwebrender_build-e45713a47a403fd9.rlib' --extern 'wr_malloc_size_of=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libwr_malloc_size_of-3ddda6e7661586c3.rlib' -C opt-level=2 -C debuginfo=2 -Dwarnings
01:55:33 ERROR - error[E0609]: no field resources on type &mut frame_builder::FrameVisibilityState<'_>
01:55:33 INFO - --> gfx\wr\webrender\src\picture.rs:765:14
01:55:33 INFO - |
01:55:33 INFO - 765 | .resources
01:55:33 INFO - | ^^^^^^^^^
01:55:33 ERROR - error: aborting due to previous error
01:55:33 INFO - For more information about this error, try rustc --explain E0609.
01:55:33 ERROR - error: Could not compile webrender.
01:55:33 INFO - Caused by:
01:55:33 INFO - process didn't exit successfully: z:/build/build/src/rustc/bin/rustc.exe --crate-name webrender 'gfx\wr\webrender\src\lib.rs' --color never --crate-type lib --emit=dep-info,link -C opt-level=2 -C panic=abort -C codegen-units=1 --cfg 'feature="capture"' --cfg 'feature="debug_renderer"' --cfg 'feature="ron"' --cfg 'feature="serde"' --cfg 'feature="serialize_program"' --cfg 'feature="webrender_api"' --cfg 'feature="webrender_build"' -C metadata=ace6f8174f505516 -C extra-filename=-ace6f8174f505516 --out-dir 'z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps' --target i686-pc-windows-msvc -L 'dependency=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps' -L 'dependency=z:/build/build/src/obj-firefox\release\deps' --extern 'app_units=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libapp_units-c090f6e457460f7a.rlib' --extern 'bincode=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libbincode-b688a9fce63efa4f.rlib' --extern 'bitflags=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libbitflags-903a48f521d1339a.rlib' --extern 'byteorder=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libbyteorder-59ce1c64327b935e.rlib' --extern 'cfg_if=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libcfg_if-a4ea9281d920b328.rlib' --extern 'dwrote=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libdwrote-1a469abaf11b1f0c.rlib' --extern 'fxhash=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libfxhash-4d13a25586fdfbb2.rlib' --extern 'gleam=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libgleam-8d9d2e529997f7c8.rlib' --extern 'lazy_static=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\liblazy_static-0a59681ddeed70e4.rlib' --extern 'log=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\liblog-7997b142f01e9feb.rlib' --extern 'malloc_size_of_derive=z:/build/build/src/obj-firefox\release\deps\malloc_size_of_derive-50fd03ce294d97e4.dll' --extern 'num_traits=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libnum_traits-7d0b2b115efd545e.rlib' --extern 'plane_split=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libplane_split-ec0507230ee8af02.rlib' --extern 'rayon=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\librayon-08f5439af5568384.rlib' --extern 'ron=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libron-f678f5a156975e65.rlib' --extern 'serde=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libserde-72281521555d1ae6.rlib' --extern 'sha2=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libsha2-d80f8598244aca59.rlib' --extern 'smallvec=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libsmallvec-237ef6bf5125e302.rlib' --extern 'thread_profiler=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libthread_profiler-5d8186d977e070fe.rlib' --extern 'time=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libtime-133b3f80cc2650a3.rlib' --extern 'webrender_api=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libwebrender_api-2bd0396cbe5b2e17.rlib' --extern 'webrender_build=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libwebrender_build-e45713a47a403fd9.rlib' --extern 'wr_malloc_size_of=z:/build/build/src/obj-firefox\i686-pc-windows-msvc\release\deps\libwr_malloc_size_of-3ddda6e7661586c3.rlib' -C opt-level=2 -C debuginfo=2 -Dwarnings (exit code: 1)
01:55:33 INFO - warning: build failed, waiting for other jobs to finish...
01:55:33 INFO - error: build failed
01:55:33 INFO - z:/build/build/src/config/rules.mk:1030: recipe for target 'force-cargo-library-build' failed
01:55:33 INFO - mozmake.EXE[5]: *** [force-cargo-library-build] Error 101
01:55:33 INFO - mozmake.EXE[5]: Leaving directory 'z:/build/build/src/obj-firefox/toolkit/library/rust'
01:55:33 INFO - mozmake.EXE[5]: Entering directory 'z:/build/build/src/obj-firefox/dom/xhr'
01:55:33 INFO - z:/build/build/src/clang/bin/clang.exe --driver-mode=cl -fms-compatibility-version=19.15.26726 -m32 -FoUnified_cpp_dom_xhr0.i_o -c -Iz:/build/build/src/obj-firefox/dist/stl_wrappers -DNDEBUG=1 -DTRIMMED=1 -DWIN32_LEAN_AND_MEAN -D_WIN32 -DWIN32 -D_CRT_RAND_S -DCERT_CHAIN_PARA_HAS_EXTRA_FIELDS -DOS_WIN=1 -D_UNICODE -DCHROMIUM_BUILD -DU_STATIC_IMPLEMENTATION -DUNICODE -D_WINDOWS -D_SECURE_ATL -DCOMPILER_MSVC -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -Iz:/build/build/src/dom/xhr -Iz:/build/build/src/obj-firefox/dom/xhr -Iz:/build/build/src/dom/base -Iz:/build/build/src/dom/file -Iz:/build/build/src/netwerk/base -Iz:/build/build/src/obj-firefox/ipc/ipdl/_ipdlheaders -Iz:/build/build/src/ipc/chromium/src -Iz:/build/build/src/ipc/glue -Iz:/build/build/src/obj-firefox/dist/include -Iz:/build/build/src/obj-firefox/dist/include/nspr -Iz:/build/build/src/obj-firefox/dist/include/nss -MD -FI z:/build/build/src/obj-firefox/mozilla-config.h -DMOZILLA_CLIENT -Qunused-arguments -Qunused-arguments -TP -nologo -w15038 -wd5026 -wd5027 -Zc:sizedDealloc- -wd4091 -wd4577 -D_HAS_EXCEPTIONS=0 -W3 -Gy -Zc:inline -arch:SSE2 -Gw -wd4251 -wd4244 -wd4267 -wd4800 -wd4595 -wd4065 -Wno-inline-new-delete -Wno-invalid-offsetof -Wno-microsoft-enum-value -Wno-microsoft-include -Wno-unknown-pragmas -Wno-ignored-pragmas -Wno-deprecated-declarations -Wno-invalid-noreturn -Wno-inconsistent-missing-override -Wno-implicit-exception-spec-mismatch -Wno-unused-local-typedef -Wno-ignored-attributes -Wno-used-but-marked-unused -we4553 -D_SILENCE_TR1_NAMESPACE_DEPRECATION_WARNING -GR- -Zi -Xclang -load -Xclang z:/build/build/src/obj-firefox/build/clang-plugin/clang-plugin.dll -Xclang -add-plugin -Xclang moz-check -O2 -Oy- -WX -fprofile-instr-generate -Xclang -finstrument-functions-after-inlining -Xclang -MP -Xclang -dependency-file -Xclang .deps/Unified_cpp_dom_xhr0.i_o.pp -Xclang -MT -Xclang Unified_cpp_dom_xhr0.i_o -Fdgenerated.pdb -FS z:/build/build/src/obj-firefox/dom/xhr/Unified_cpp_dom_xhr0.cpp
01:55:33 INFO - mozmake.EXE[5]: Leaving directory 'z:/build/build/src/obj-firefox/dom/xhr'
01:55:33 INFO - z:/build/build/src/config/recurse.mk:74: recipe for target 'toolkit/library/rust/target' failed
01:55:33 INFO - mozmake.EXE[4]: *** [toolkit/library/rust/target] Error 2
01:55:33 INFO - mozmake.EXE[4]: *** Waiting for unfinished jobs....
01:55:33 INFO - mozmake.EXE[5]: Entering directory 'z:/build/build/src/obj-firefox/dom/plugins/test/testplugin'
01:55:33 INFO - dom/plugins/test/testplugin/nptest.dll
01:55:33 INFO - z:/build/build/src/clang/bin/lld-link.exe -NOLOGO -DLL -OUT:nptest.dll -PDB:nptest.pdb -SUBSYSTEM:WINDOWS,6.01 -MACHINE:X86 Unified_cpp_test_testplugin0.obj nptest.res -LARGEADDRESSAWARE -RELEASE -SAFESEH -DEBUG -OPT:REF,ICF -DEF:../../../../../dom/plugins/test/testplugin/nptest.def kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib secur32.lib msimg32.lib imm32.lib
01:55:33 INFO - lld-link.exe: warning: ignoring unknown argument: -RELEASE
01:55:33 INFO - mozmake.EXE[5]: Leaving directory 'z:/build/build/src/obj-firefox/dom/plugins/test/testplugin'
01:55:33 INFO - mozmake.EXE[5]: Entering directory 'z:/build/build/src/obj-firefox/dom/plugins/test/testplugin'
01:55:33 INFO - z:/build/build/src/obj-firefox/_virtualenvs/init/Scripts/python.exe -m mozbuild.action.check_binary --target nptest.dll
01:55:33 INFO - mozmake.EXE[5]: Leaving directory 'z:/build/build/src/obj-firefox/dom/plugins/test/testplugin'

Flags: needinfo?(bobbyholley)

Comment 10

4 months ago
Backout by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a15dd0f8abd3
Backed out 4 changesets for build bustages complaining no field `resources` CLOSED TREE
(Assignee)

Comment 11

4 months ago

Sigh. This was a collision with a patch that landed after the try push, and added another reference to the variable I renamed.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=357d22dd506877e74f524c460c918c038415db45

Comment 12

4 months ago
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa5836f97faf
Declare intern-related types in a structured way. r=kamidphish
https://hg.mozilla.org/integration/autoland/rev/b79c6b00e3c0
Use macros to reduce boilerplate. r=kamidphish
https://hg.mozilla.org/integration/autoland/rev/32476b4042f7
Simplify naming of interner and data_store instances. r=kamidphish
https://hg.mozilla.org/integration/autoland/rev/29dcf30c1cad
Rename the *Resource* types to be more clearly about interning. r=kamidphish
(Assignee)

Updated

4 months ago
Flags: needinfo?(bobbyholley)
You need to log in before you can comment on or make changes to this bug.