The localized aarch64 installer fail.

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: glandium, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
ARM64
Windows 10
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

5 months ago

I tried installing a aarch64 l10n build from http://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central-l10n/ (the japanese one), and after extracting, it failed with a message saying that Windows 7 x64 or more recent is required. Presumably, the installer contains the x64 binaries.

Reporter

Updated

5 months ago
Component: General → Release Automation: L10N
Product: Firefox Build System → Release Engineering
QA Contact: bugspam.Callek
Reporter

Comment 1

5 months ago

Presumably, the installer contains the x64 binaries.

I checked, it does contain the aarch64 binaries. But the installer itself doesn't know.

Reporter

Comment 2

5 months ago

This is the log of one of the nightly l10n jobs for aarch64:
https://taskcluster-artifacts.net/HGIgcv9VTUeUGgZVPbAkfA/0/public/logs/live_backing.log

23:44:19 INFO - 0:06.12 checking for host system type... x86_64-pc-mingw32
23:44:19 INFO - 0:06.18 checking for target system type... x86_64-pc-mingw32

well, no surprise there.

Reporter

Updated

5 months ago
Depends on: 1520874

Comment 4

5 months ago
Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/24310d684cca
Add win64-aarch64 l10n mozconfig; r=glandium
Duplicate of this bug: 1520936

Comment 6

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.