If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

set label will corrupt imap mailbox - unable to open mailbox afterwards

VERIFIED DUPLICATE of bug 152069

Status

MailNews Core
Backend
--
major
VERIFIED DUPLICATE of bug 152069
16 years ago
9 years ago

People

(Reporter: mav, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

After I set a label on a message stored in Cyrus IMAP4 v1.5.2 and restart
mozilla, the mailbox cannot be opened. There was no error message either.
Netscape 4.79 will not be able to open that mailbox either.

Reproducible: Always
Steps to Reproduce:
1. set a label on a message
2. restart mozilla

Actual Results:  The mail box will fail to open. What you will see is the old
summary loaded. It's as if you have no new mail. But when you click on any
message, the message view will be empty.

Expected Results:  Open my mail box

At the restart, mozilla will
1 capability
2 login
3 lsub "" "*"
4 list "" "INBOX"
5 select "INBOX"
6 getacl "INBOX"
7 logout

The problem is in the select (5). This is the output of the "select INBOX"
command (after setting a label). Notice the "$Label" in the flags.

5 select inbox
* FLAGS (\Answered \Flagged \Draft \Deleted \Seen  $Label  $Label  $Label  $Labe
l
maver)
* OK [PERMANENTFLAGS (\Answered \Flagged \Draft \Deleted \Seen  $Label  $Label
$Label  $Label
maver \*)]
* 4 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 967822823]
5 OK [READ-WRITE] Completed

To fix this problem, I imap into the server and do "[n] setacl INBOX maverick
lrswipcda" three times. In Cyrus IMAP4 v1.5.2, this will get rid of the "$Label"
two characters at a time. (I don't know why it's two, but that's what I saw.)
After clearing the "$Label", restart mozilla and it will just work fine.
(Reporter)

Comment 1

16 years ago
I am sorry for pressing the back button...

*** This bug has been marked as a duplicate of 152069 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified as a duplicate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.