Closed Bug 1520814 Opened 7 months ago Closed 7 months ago

Page should zoom when <meta name="viewport" content="width=xyz"> is specified

Categories

(DevTools :: Responsive Design Mode, defect)

65 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1501665

People

(Reporter: mbalfanz, Assigned: bradwerth)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

When a fixed width is specified in meta viewport, RDM should zoom the page in/out to fit.

STR:

  1. visit bugzilla.mozilla.org
  2. enter RDM with touch simulation enabled
  3. change the size of RDM

AR:

  • the site maintains a constant width

ER:

  • the site should zoom to fully fill the size of RDM and maintain the width specified in meta viewport.

See the screenshot attached to see how bugzilla scales down on an iPhone, but scales up on an iPad Pro in landscape.

Assignee: nobody → bwerth

I've decided that this approach is the correct way to handle issues raised by the proposed patches for Bug 1501665, and implementing it would significantly overwrite the work in that bug, so I'm treating this as a duplicate of Bug 1501665.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1501665
You need to log in before you can comment on or make changes to this bug.