XML Parsing Error: undefined entity Location: chrome://messenger/content/hiddenWindow.xul

RESOLVED FIXED in Thunderbird 66.0

Status

defect
--
major
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: florian, Assigned: florian)

Tracking

({regression})

unspecified
Thunderbird 66.0
Unspecified
macOS
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird65 fixed, thunderbird66 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 months ago

XML Parsing Error: undefined entity
Location: chrome://messenger/content/hiddenWindow.xul
Line Number 1248, Column 17:
<menuitem label="&openAllAttachmentsCmd.label;"

[Exception... "[JavaScript Error: "browser is null" {file: "resource:///modules/hiddenWindow.jsm" line: 16}]'[JavaScript Error: "browser is null" {file: "resource:///modules/hiddenWindow.jsm" line: 16}]' when calling method: [prplIAccount::connect]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: file:///.../obj-x86_64-apple-darwin17.7.0/dist/Thunderbird%20Daily.app/Contents/Resources/components/imAccounts.js :: connect :: line 724" data: yes]

This prevents chat accounts from connecting, making it impossible to test bug 1519091 on Mac.

This is a regression caused by bug 1519481, patch coming.

(Assignee)

Updated

3 months ago
OS: Unspecified → Mac OS X
(Assignee)

Comment 1

3 months ago
Posted patch FixSplinter Review
Attachment #9037324 - Flags: review?(jorgk)

Comment 2

3 months ago

(In reply to Florian Quèze [:florian] from comment #0)

This prevents chat accounts from connecting, making it impossible to test bug 1519091 on Mac.
This is a regression caused by bug 1519481, patch coming.

Can you please elaborate on this? You're saying chat is broken on TB 65 beta 3 which I've just built?
https://treeherder.mozilla.org/#/jobs?repo=comm-beta&revision=34e099eeadc625db313577c93d025a6958ac86b4

On Mac only? It works fine on Windows, I've just tried it. What is that hiddenWindow.xul about?

Flags: needinfo?(florian)
(Assignee)

Comment 3

3 months ago

(In reply to Jorg K (GMT+1) from comment #2)

On Mac only?

Yes.

It works fine on Windows, I've just tried it. What is that hiddenWindow.xul about?

The code that you broke ensures we have a correct menubar at the top of the screen when Thunderbird is the active application but has no window.

Chat accounts fail to connect with the error I pasted in comment 0, because https://searchfox.org/comm-central/source/chat/modules/hiddenWindow.jsm breaks completely when the hidden window encounters a parse error.

Flags: needinfo?(florian)

Comment 4

3 months ago
Comment on attachment 9037324 [details] [diff] [review]
Fix

Sorry about the regression, we tested the other two platforms. I'll handle the landing.
Attachment #9037324 - Flags: review?(jorgk) → review+

Comment 5

3 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/4badb35825a8
include msgHdrViewOverlay.dtd in hiddenWindow.xul to fix bustage caused by bug 1519481. r=jorgk DONTBUILD

Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 66.0
You need to log in before you can comment on or make changes to this bug.