Mozilla will not start up on Mac OS 8.6

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: barkofdelight, Assigned: Matti)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have a Mac G4 running OS 8.6

I've checked the compatibility info that I can find and don't have any 
extensions or plugins that should cause trouble.

I note with suspicion that the installer didn't give me a "installation was 
successful" message. It just quit (when it appeared to be done).

Other than that, I don't have many clues. When I double-click on the 
program, it simply quits without any message or error. Sometimes it 
shows the flash screen and hangs.

Once (and just once) it ran that error-reporting program to send info 
automatically, but I didn't do anything different so I don't know what caused 
that behavior.

I'm sure I've got some incompatibility, but looking through the extensions I 
have they all seem pretty mainstream. I haven't tried booting from a CD or 
with extensions disabled. While that may provide some diagnostic 
information, I'm sure you understand it's not really a viable workaround if it 
succeeds.

Thanks for any help. I use Mozilla at work on an Intel Linux machine and I 
love it!

K.
(Reporter)

Comment 1

16 years ago
Anybody reading this?

Since posting this bug, I tried running Mozilla 1.0 on various Macs running 
OS 8.6, none of them can sucessfully launch.

Is this simply an error in documentation? Perhaps OS 9 is required?

Thanks,

Comment 2

16 years ago
This works fine for me. Tested 1.0 and 1.1beta milestones on Mac OS 8.6. I've
got all the latest updates for 8.6. 

Comment 3

16 years ago
barkofdelight@yahoo.com, if you can, run the TalkBack application again and see if it still lists 
the report ID. If it does, let us know what it is.
Severity: normal → critical
Summary: Mozilla will not start up on my Macintosh → Mozilla will not start up on Mac OS 8.6
(Reporter)

Comment 4

16 years ago
Right now I'm away from home, so I can't get additional information.
Asa suggested I try updating Carbon Lib (It did have an update
beyond the version released with 8.6) and I will try that when 
I can -- probably late in August.

Comment 5

16 years ago
Possible dup of bug 154932?
(Reporter)

Comment 6

16 years ago
Tried upgrading to CarbonLib 1.4 (which is what the OS 9.2 system
is using -- and Mozilla works there) but still it doesn't work.

Any other guesses as to the offending library?

Thanks,

Comment 7

16 years ago
barkofdelight@yahoo.com, you mentioned you're testing 1.0. There were some problems with 
Mozilla on Mac OS 8.6 that weren't fixed until after 1.0 shipped. Can you reproduce this using a 
more recent build, like 1.1b or a recent nightly?
(Reporter)

Comment 8

16 years ago
Running 1.1b works just fine!

(Now we're not sure if the carbon lib played a role or not.....)

Thanks to all!
wfm..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.