Intermittent mathml/font-inflation-1.html == mathml/font-inflation-1-ref.html | image comparison, max difference: 168, number of differing pixels: 260

REOPENED
Assigned to

Status

()

defect
P5
normal
REOPENED
5 months ago
8 days ago

People

(Reporter: intermittent-bug-filer, Assigned: andrei_ciure)

Tracking

({intermittent-failure, leave-open})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell disabled])

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

5 months ago
treeherder

Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=222540099&repo=autoland

https://queue.taskcluster.net/v1/task/IhIs7SjNTrmjNqb_LzxRsA/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/IhIs7SjNTrmjNqb_LzxRsA/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

12:08:44 INFO - REFTEST TEST-LOAD | file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/font-inflation-1-ref.html | 370 / 387 (95%)
12:08:44 INFO - ++DOMWINDOW == 23 (0x112accc00) [pid = 875] [serial = 1032] [outer = 0x112cbd800]
12:08:44 INFO - REFTEST INFO | REFTEST fuzzy test (0, 0) <= (168, 260) <= (255, 244)
12:08:46 INFO - REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/font-inflation-1.html == file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/font-inflation-1-ref.html | image comparison, max difference: 168, number of differing pixels: 260
12:08:46 INFO - REFTEST IMAGE 1 (TEST): data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAyAAAAPoCAYAAAAmy5qxAAAgAElEQVR4nOy9z+v93nbXH0TEiUPHDsQ/wCA
12:08:46 INFO - REFTEST IMAGE 2 (REFERENCE): data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAyAAAAPoCAYAAAAmy5qxAAAgAElEQVR4nOy9vcv83lb/nX/gtOcPsLCwsAgIp7GWKWy
12:08:46 INFO - --DOMWINDOW == 22 (0x10b9d7800) [pid = 875] [serial = 1014] [outer = 0x0] [url = file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/mfrac-D-1-ref.html]
12:08:46 INFO - --DOMWINDOW == 21 (0x112ac4400) [pid = 875] [serial = 1015] [outer = 0x0] [url = data:text/html;charset=UTF-8,%3C%21%2D%2DCLEAR%2D%2D%3E]
12:08:46 INFO - --DOMWINDOW == 20 (0x112abf400) [pid = 875] [serial = 1011] [outer = 0x0] [url = file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/mfrac-C-4-ref.html]
12:08:46 INFO - --DOMWINDOW == 19 (0x112ac3000) [pid = 875] [serial = 1013] [outer = 0x0] [url = file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/mfrac-D-1.html]
12:08:46 INFO - --DOMWINDOW == 18 (0x112ac5400) [pid = 875] [serial = 1016] [outer = 0x0] [url = file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/mfrac-D-2.html]
12:08:46 INFO - --DOMWINDOW == 17 (0x112ac6000) [pid = 875] [serial = 1017] [outer = 0x0] [url = file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/mfrac-D-2-ref.html]
12:08:46 INFO - --DOMWINDOW == 16 (0x112abfc00) [pid = 875] [serial = 1012] [outer = 0x0] [url = data:text/html;charset=UTF-8,%3C%21%2D%2DCLEAR%2D%2D%3E]
12:08:46 INFO - --DOMWINDOW == 15 (0x112acc400) [pid = 875] [serial = 1018] [outer = 0x0] [url = data:text/html;charset=UTF-8,%3C%21%2D%2DCLEAR%2D%2D%3E]
12:08:46 INFO - --DOMWINDOW == 14 (0x112acd800) [pid = 875] [serial = 1019] [outer = 0x0] [url = file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/mfrac-D-3.html]
12:08:46 INFO - REFTEST TEST-END | file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/font-inflation-1.html == file:///Users/cltbld/tasks/task_1547755329/build/tests/reftest/tests/layout/reftests/mathml/font-inflation-1-ref.html
12:08:46 INFO - ++DOMWINDOW == 15 (0x112abfc00) [pid = 875] [serial = 1033] [outer = 0x112cbd800]

Duplicate of this bug: 1520950
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

There are 34 failures in the last 7 days.
They occur on macosx64-qr debug.
Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=225185598&repo=mozilla-central&lineNumber=52859
Anthony: Hi, can you please have a look at this? Thanks!

Flags: needinfo?(ajones)
Whiteboard: [stockwell needswork:owner}
Comment hidden (Intermittent Failures Robot)

(In reply to Eliza Balazs [:ebalazs_] from comment #4)

There are 34 failures in the last 7 days.
They occur on macosx64-qr debug.
Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=225185598&repo=mozilla-central&lineNumber=52859
Anthony: Hi, can you please have a look at this? Thanks!

Feel free to disable the test.

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(ajones)
Resolution: --- → FIXED
Assignee

Comment 7

4 months ago
Posted patch bug1520910.patch (obsolete) — Splinter Review
Flags: needinfo?(jmaher)
Attachment #9041440 - Flags: review?(jmaher)
Comment on attachment 9041440 [details] [diff] [review]
bug1520910.patch

Review of attachment 9041440 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/reftests/mathml/reftest.list
@@ +368,4 @@
>  == mfrac-D-4.html mfrac-D-4-ref.html
>  == mfrac-E-1.html mfrac-E-1-ref.html
>  == shadow-dom-1.html shadow-dom-1-ref.html
> +pref(dom.meta-viewport.enabled,true) pref(font.size.inflation.emPerLine,25) fuzzy-if(webrender&&!gtkWidget,0-255,0-244) skip-if(cocoaWidget && debug) == font-inflation-1.html font-inflation-1-ref.html

I believe we can expand the fuzzy from:
(webrender&&!gtkWidget,0-255,0-244)

to:
(webrender&&!gtkWidget,0-255,0-260)

that is assuming the bug title is correct.

Otherwise, the skip-if is the way to go and here we would need to change:
skip-if(cocoaWidget && debug)

to be:
skip-if(cocoaWidget&&webrender&&debug)


I would prefer adjusting the fuzzy-if
Attachment #9041440 - Flags: review?(jmaher) → review-
Flags: needinfo?(jmaher)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 11

4 months ago

I updated the fuzzy-if, if the failure rate doesn't decrease, we'll use skip-if

Assignee: nobody → aciure
Attachment #9041440 - Attachment is obsolete: true
Flags: needinfo?(jmaher)
Comment hidden (Intermittent Failures Robot)
Flags: needinfo?(jmaher)
Whiteboard: [stockwell needswork:owner} → [stockwell disabled]

Comment 13

4 months ago

Pushed by aiakab@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fbe70e26f7ff
disable font-inflation-1-ref.html for frequent failures. r=jmaher

Keywords: checkin-needed
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.