gather information on x86-on-aarch64 clients

RESOLVED FIXED in Firefox 67

Status

()

enhancement
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: froydnj, Assigned: froydnj)

Tracking

(Blocks 2 bugs)

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed, firefox68 fixed)

Details

Attachments

(3 attachments)

Assignee

Description

5 months ago

This would be useful information to know, to encourage people there's a better
firefox experience out there.

Assignee

Comment 1

5 months ago
In addition to knowing whether we're running x86-on-x86-64, we'd also
like to know about the x86-on-arm64 case.  The current code doesn't
provide enough information to determine that, so we need to query a
little bit harder.
Attachment #9037389 - Flags: review?(aklotz)
Assignee

Comment 2

5 months ago
Please let me know if there's something more detailed I need to do here.
Attachment #9037390 - Flags: review?(chutten)
Attachment #9037389 - Flags: review?(aklotz) → review+
Assignee

Updated

5 months ago

Comment 3

5 months ago
Comment on attachment 9037390 [details] [diff] [review]
part 2 - send isWowARM64 through telemetry

Review of attachment 9037390 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good and complete to me. It'll need [Data Collection Review](https://wiki.mozilla.org/Firefox/Data_Collection), of course, but technically speaking this covers code, docs, and test.

::: toolkit/components/telemetry/docs/data/environment.rst
@@ +89,5 @@
>        system: {
>          memoryMB: <number>,
>          virtualMaxMB: <number>, // windows-only
>          isWow64: <bool>, // windows-only
> +	isWowARM64: <bool>, // windows-only

I'd love a one-liner about what isWowARM64 means. Something like "true if running a non-arm64 build of Firefox on an arm64 build of Windows" (...is that even true?)
Attachment #9037390 - Flags: review?(chutten) → review+

Comment 4

5 months ago
Comment on attachment 9037390 [details] [diff] [review]
part 2 - send isWowARM64 through telemetry

Review of attachment 9037390 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/components/telemetry/docs/data/environment.rst
@@ +89,5 @@
>        system: {
>          memoryMB: <number>,
>          virtualMaxMB: <number>, // windows-only
>          isWow64: <bool>, // windows-only
> +	isWowARM64: <bool>, // windows-only

Wait a minute, is that a tab character? Tabs should be spaces in this file.

There are some r+ patches which didn't land and no activity in this bug for 2 weeks.
:froydnj, could you have a look please?

Flags: needinfo?(nfroyd)
Assignee

Comment 6

3 months ago

Data review filled out. Be gentle, please! :)

Flags: needinfo?(nfroyd)
Attachment #9054323 - Flags: data-review?(chutten)

Comment 7

3 months ago
Comment on attachment 9054323 [details]
data-review-answers.txt

Preliminary note:

Please file a follow-up bug for removing or renewing this collection before it expires.

DATA COLLECTION REVIEW RESPONSE:

    Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes. This collection is part of the Telemetry Environment so is documented in its documentation here: https://firefox-source-docs.mozilla.org/toolkit/components/telemetry/telemetry/data/environment.html

    Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

    If the request is for permanent data collection, is there someone who will monitor the data over time?

No. This collection will expire in 6 months.

    Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 1, Technical.

    Is the data collection request for default-on or default-off?

Default on for all channels.

    Does the instrumentation include the addition of any new identifiers?

No.

    Is the data collection covered by the existing Firefox privacy notice?

Yes.

    Does there need to be a check-in in the future to determine whether to renew the data?

Yes. Nathan Froyd is responsible for renewing or removing the collection before September 29, 2019.

---
Result: datareview+
Attachment #9054323 - Flags: data-review?(chutten) → data-review+

Comment 8

3 months ago

Nathan, is this ready to land?

Flags: needinfo?(nfroyd)
Assignee

Comment 9

3 months ago

(In reply to Eric Rahm [:erahm] from comment #8)

Nathan, is this ready to land?

Yes, currently waiting for inbound to reopen since it's be closed...all afternoon and evening.

Flags: needinfo?(nfroyd)

Updated

3 months ago
Blocks: 1541292

Comment 10

3 months ago
Pushed by nfroyd@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d49485b4f422
part 1 - add an isWowARM64 property to nsSystemInfo; r=aklotz
https://hg.mozilla.org/integration/mozilla-inbound/rev/67a15c8abdbc
part 2 - send isWowARM64 through telemetry; r=chutten,data-review=chutten

Comment 11

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Nathan, should we uplift this?

Flags: needinfo?(nfroyd)
Assignee

Comment 13

3 months ago

Comment on attachment 9037389 [details] [diff] [review]
part 1 - add an isWowARM64 property to nsSystemInfo

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: Minimal impact on users. Mozilla won't be able to determine whether some users are running x86 builds on aarch64 windows, and therefore could benefit from a faster native experience.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk: adding a little bit of well-understood code and some telemetry on top.
  • String changes made/needed: None
Flags: needinfo?(nfroyd)
Attachment #9037389 - Flags: approval-mozilla-beta?
Assignee

Updated

3 months ago
Attachment #9037390 - Flags: approval-mozilla-beta?
Comment on attachment 9037389 [details] [diff] [review]
part 1 - add an isWowARM64 property to nsSystemInfo

Additional telemetry for ARM64, low risk, uplift approved for 67 beta 10, thanks.
Attachment #9037389 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9037390 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.