Remove redundant theme-fg-color classes

RESOLVED FIXED in Firefox 66

Status

enhancement
P3
normal
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: fvsch, Assigned: fvsch)

Tracking

unspecified
Firefox 66

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

5 months ago

Searching through the CSS codebase, it seems we're always styling the theme-fg-color5 exactly like theme-fg-color3. We may have reduced the number of displayed colors in the past.

So we can deduplicate those.

Same for theme-fg-color2 which is only used once and styled like theme-fg-color1.

Assignee

Updated

5 months ago
Summary: Remove theme-fg-color5 class (duplicate of theme-fg-color3) → Remove redundant theme-fg-color classes
Assignee

Comment 2

5 months ago

In this patch I'm keeping 3 theme-fg-color* classes:

Assignee

Updated

5 months ago
Assignee: nobody → florens
Status: NEW → ASSIGNED
Priority: -- → P3

Comment 3

5 months ago
Pushed by florens@fvsch.com:
https://hg.mozilla.org/integration/autoland/rev/58e82b793e1c
Remove redundant theme-fg-color classes; r=pbro

Comment 4

5 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.