[Pointer Events] Duplicated pointerdown event in multi touches

RESOLVED FIXED in Firefox 66

Status

()

defect
P2
normal
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: edgar, Assigned: edgar)

Tracking

(Blocks 1 bug)

unspecified
mozilla67
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox66 fixed, firefox67 fixed)

Details

Attachments

(2 attachments)

Assignee

Description

5 months ago
No description provided.
Assignee

Comment 1

5 months ago
Posted file bug_1521082.html

STR:

  1. Press screen with the first finger (do not release it)
  2. Press with another finger.

Actual results:
A duplicated pointerdown event is fired for first press.

Expected results:
There should only one pointerdown event fired for first press.

Assignee

Updated

5 months ago
Assignee: nobody → echen
Blocks: pointerevent
Priority: -- → P2
See Also: → 1493360

I wonder why (manual) wpt tests for pointer events didn't catch this.

Attachment #9039686 - Attachment description: Bug 1521082 - Don't dispatch pointer event if the touch in touchstart event is alyready registered; → Bug 1521082 - Don't dispatch pointer event if the touch in touchstart event is already registered;

Comment 5

5 months ago
Pushed by echen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2ebf1cc8b875
Don't dispatch pointer event if the touch in touchstart event is already registered; r=smaug
Assignee

Updated

5 months ago
Blocks: 1505321

Comment 6

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee

Updated

5 months ago
Blocks: 1493360
See Also: 1493360
Assignee

Updated

5 months ago
Blocks: 1524251
Assignee

Updated

5 months ago
No longer blocks: 1524251
Assignee

Updated

4 months ago
Duplicate of this bug: 1493360

This is a major improvement for ARM arch and Windows, I think it's worth uplifting to 66.
Edgar, can you please prepare a uplift request?

Flags: needinfo?(echen)
Assignee

Comment 9

4 months ago

Comment on attachment 9039686 [details]
Bug 1521082 - Don't dispatch pointer event if the touch in touchstart event is already registered;

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

None

User impact if declined

The pinch to zoom in/out on google map on touch screen device doesn't work, it always goes to maximum zoom.
It is a really bad experience on google map on touch screen devices.

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

The changes is small, only affects pointer event on touch screen device and also make our behavior align with other browsers.

String changes made/needed

None

Flags: needinfo?(echen)
Attachment #9039686 - Flags: approval-mozilla-beta?

Comment on attachment 9039686 [details]
Bug 1521082 - Don't dispatch pointer event if the touch in touchstart event is already registered;

Fix for pinch to zoom on touch screens, let's uplift for beta 6.

Is this something that never worked correctly in this case, or, is it a regression?
Or, maybe this site changed recently?

Flags: needinfo?(echen)
Attachment #9039686 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Thanks for adding new tests, too!

Flags: in-testsuite+
Assignee

Comment 13

4 months ago

(In reply to Liz Henry (:lizzard) (use needinfo) from comment #10)

Is this something that never worked correctly in this case, or, is it a regression?
Or, maybe this site changed recently?

I am not sure if site changed recently.
For pointer event, this is not a regression, it is something that never worked correctly.

Flags: needinfo?(echen)
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.