In WPT reftest screenshot data-URI logging, the second data URI has "Pausing until the browser exits" added to the end of it

RESOLVED FIXED in Firefox 66

Status

defect
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: dholbert, Assigned: jgraham)

Tracking

Version 3
mozilla66
Points:
---

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 months ago
Posted file mylog.txt

STR:

  1. Run the following, using a reftest that is known to fail:
./mach test --reftest-screenshot=fail \
--log-tbpl mylog.txt  testing/web-platform/tests/css/vendor-imports/mozilla/mozilla-central-reftests/flexbox/flexbox-justify-content-horiz-001b.xhtml

(Use some test that is known/expected to fail; this particular one may start passing when bug 1520946 lands in the next few days.)

  1. Inspect your log file.

ACTUAL RESULTS: In my case, the line with the second data URI ends with the string "Pausing until the browser exits". It looks like this (I've ellipsized the data for brevity):

REFTEST   IMAGE 2 (REFERENCE): data:image/png;base64,iVBO[...]YII=Pausing until the browser exits

EXPECTED RESULTS:
Logging like "Pausing until the browser exits" should go on its own line

(Reporter)

Comment 1

4 months ago

In case it matters, I'm using a debug build (ac_add_options --enable-debug --disable-optimize), built from this cset:
https://hg.mozilla.org/integration/autoland/rev/b0377ec57ddd

(Reporter)

Comment 2

4 months ago

At first I suspected that maybe there was a race condition involved with some randomness, but FWIW, this happened to me three times in a row (i.e. I performed the STR 3x, using three different log files, and all three had this issue).

So it seems to be 100% reproducible at least on my end.

(Reporter)

Comment 3

4 months ago

This breaks reftest-analyzer[1], as you might expect. In particular: if you...

  1. copypaste the three lines starting with "TEST-FAIL" from my attached log into reftest-analyzer.xhtml (including this bug's "Pausing" junk at the end of the third line)
  2. Manually do s/TEST-FAIL/TEST-KNOWN-FAIL/ as-needed per bug 1521147

...then reftest-analyzer will happily process your submission, but it shows "image not available" when you try to view the second image.

[1] https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml

Comment 5

4 months ago
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/e170cff6c5a5
Ensure reftest screenshots are followed by a newline when expected, r=ahal

Comment 6

4 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
https://hg.mozilla.org/projects/cedar/rev/e170cff6c5a54e58b5496c43694d85601b1bcf0d
Bug 1521140 - Ensure reftest screenshots are followed by a newline when expected, r=ahal
Assignee: nobody → james
You need to log in before you can comment on or make changes to this bug.