Closed Bug 1521253 Opened 2 years ago Closed 1 year ago

Intermittent layout/style/test/test_property_syntax_errors.html | Test timed out.

Categories

(Core :: Layout, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: emilio)

References

(Regression)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=222796773&repo=autoland

https://queue.taskcluster.net/v1/task/PneHaurlQPyU5FJmqE-tag/runs/0/artifacts/public/logs/live_backing.log

[task 2019-01-19T01:05:43.602Z] 01:05:43 INFO - 139 INFO TEST-PASS | layout/style/test/test_property_syntax_errors.html | invalid value 'path('M 10-10 20')' not accepted for 'offset-path' property
[task 2019-01-19T01:05:43.603Z] 01:05:43 INFO - 140 INFO TEST-PASS | layout/style/test/test_property_syntax_errors.html | invalid value 'offset-path: path('M 10-10 20')' is balanced and does not lead to parsing errors afterwards
[task 2019-01-19T01:05:43.605Z] 01:05:43 INFO - 141 INFO TEST-PASS | layout/style/test/test_property_syntax_errors.html | invalid value 'path('M 10 10 C 20 20 40 20')' not accepted for 'offset-path' property
[task 2019-01-19T01:05:43.606Z] 01:05:43 INFO - 142 INFO TEST-PASS | layout/style/test/test_property_syntax_errors.html | invalid value 'path('M 10 10 C 20 20 40 20')' not accepted for 'offset-path' property
[task 2019-01-19T01:05:43.607Z] 01:05:43 INFO - 143 INFO TEST-PASS | layout/style/test/test_property_syntax_errors.html | invalid value 'offset-path: path('M 10 10 C 20 20 40 20')' is balanced and does not lead to parsing errors afterwards
[task 2019-01-19T01:05:43.608Z] 01:05:43 INFO - Buffered messages finished
[task 2019-01-19T01:05:43.646Z] 01:05:43 INFO - 144 INFO TEST-UNEXPECTED-FAIL | layout/style/test/test_property_syntax_errors.html | Test timed out.
[task 2019-01-19T01:05:43.647Z] 01:05:43 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:7
[task 2019-01-19T01:05:43.649Z] 01:05:43 INFO - reportError@SimpleTest/TestRunner.js:121:7
[task 2019-01-19T01:05:43.649Z] 01:05:43 INFO - TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:7
[task 2019-01-19T01:05:43.649Z] 01:05:43 INFO - 145 ERROR [SimpleTest.finish()] this test already called finish!
[task 2019-01-19T01:05:43.650Z] 01:05:43 INFO - 146 INFO TEST-UNEXPECTED-ERROR | layout/style/test/test_property_syntax_errors.html | called finish() multiple times
[task 2019-01-19T01:05:43.650Z] 01:05:43 INFO - TEST-INFO took 632585ms
[task 2019-01-19T01:05:43.651Z] 01:05:43 INFO - 147 INFO TEST-OK | layout/style/test/test_property_syntax_errors.html

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Flags: needinfo?(emilio)
Duplicate of this bug: 1484418
Assignee: nobody → emilio
Flags: needinfo?(emilio)

Bug 1547939 added a bunch of extra tests for three properties (background, mask,
and -webkit-mask). This made them time out more frequently in the Android
emulator.

Request a longer timeout to address this. Alternative is maybe just removing the
tests or such, I don't think they're of particularly great value.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/704947d53e4c
Request longer timeouts in two tests that frequently time out in the Android emulator. r=dholbert
Status: REOPENED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
See Also: → 1548765
You need to log in before you can comment on or make changes to this bug.